Project

General

Profile

Actions

Bug #21466

closed

Deprecate serverTimezone

Added by Dmitry Dulepov over 14 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Could have
Assignee:
Category:
-
Target version:
Start date:
2009-11-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This setting is not used in the core and can be removed to prevent confusion.

(issue imported from #M12478)


Files

12748.diff (2.59 KB) 12748.diff Alexander Opitz, 2013-05-14 11:23

Related issues 2 (1 open1 closed)

Related to TYPO3 Core - Bug #51918: Native date and datetime values do not consider timezoneClosed2013-09-11

Actions
Related to TYPO3 Core - Feature #61110: Support for timezones in all date fields in TYPO3 BENew2014-08-21

Actions
Actions #1

Updated by Andreas Kie├čling almost 14 years ago

Hi Dmitry,

would you mind sending this to core list? I just stumbled upon this setting and also didn't find any place where it is used.

Actions #2

Updated by Alexander Opitz about 11 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

As this report is very old, is the handling in newer TYPO3 CMS Versions (like 6.0/6.1) more like you expect it?

Actions #3

Updated by Simon Schaufelberger about 11 years ago

Alexander, why do ask? Nothing has changed here. what do you mean with "more like you expect it"?

Actions #4

Updated by Alexander Opitz about 11 years ago

Fix diff from Mantis import

Actions #5

Updated by Alexander Opitz about 11 years ago

  • File deleted (12748.diff)
Actions #6

Updated by Alexander Opitz about 11 years ago

The serverTimeZone config is used on "date" fields, so the setting is used.

Actions #8

Updated by Oliver Hader almost 11 years ago

  • Assignee set to Oliver Hader
  • Is Regression set to No

In TYPO3 CMS 6.2 the serverTimeZone is still present...
Working on issue #51918, I found this issue and agree that serverTimeZone does not make much sense...

Actions #9

Updated by Oliver Hader almost 11 years ago

  • Target version set to 6.2.0
Actions #10

Updated by Oliver Hader almost 11 years ago

  • Status changed from Needs Feedback to Accepted
Actions #11

Updated by Stefan Neufeind almost 10 years ago

Since 6.2 is out the door now, can we declare serverTimeZone (and maybe others) as deprecated officially and maybe not set it by default? It's not used in core, and that would give a clear signal that extensions should not rely on the setting.

Actions #12

Updated by Benni Mack almost 9 years ago

  • Status changed from Accepted to Closed

fixed in master

Actions

Also available in: Atom PDF