Bug #21975

Web->Function: empty frame if all related ext removed

Added by Michael Schams almost 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-01-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

After removing (de-installation, not physically deleting) all relevant system extensions (func_wizards, wizard_crpages and wizard_sortpages), the function "Web>Function" shows an empty target page in right frame.

This sounds reasonable, because there are no functions available to show to the end-user, but an empty page/frame is misleading and looks like system fault (may confuse end-user). Please note: the user who sees the empty screen is not reasonable the person who deleted the sysExtensions.

Suggested solution: hide "Function" in "Web>Function" if no functionality is available (best solution) or show warning message - not an empty page (alternative solution).

How to reproduce:

Login -> TYPO3 BE (admin rights).
Admin Tools -> Extension Manager -> Select box: "Install Extension" (display shy extensions: YES)
Section "Backend Modules":
Remove (uninstall) extensions: wizard_crpages, wizard_sortpages and func_wizards (in this order), see attached screenshot008.jpg

Issue: in section "Web", the menu link "Functions" is still available, see attached screenshot009.jpg

Click: "Web>Functions" and select any page in the page tree.
Issue: frame (right hand side) is empty, no message appears, see attached screenshot010.jpg
(issue imported from #M13266)


Files

screenshot008.jpg (229 KB) screenshot008.jpg Administrator Admin, 2010-01-17 11:09
screenshot009.jpg (62.8 KB) screenshot009.jpg Administrator Admin, 2010-01-17 11:09
screenshot010.jpg (57.4 KB) screenshot010.jpg Administrator Admin, 2010-01-17 11:09
screenshot0001-typo3-6.0.x.png (63.7 KB) screenshot0001-typo3-6.0.x.png Michael Schams, 2013-05-17 10:31
screenshot0002-typo3-6.0.x.png (56.7 KB) screenshot0002-typo3-6.0.x.png Michael Schams, 2013-05-17 10:31

Related issues

Related to TYPO3 Core - Bug #21227: Section "Help" is shown even with no subelementsClosedSteffen Kamper2009-10-10

Actions
Related to TYPO3 Core - Bug #63917: If no func wizard ext is installed, exception is thrown (due to PHP warning)Rejected2014-12-16

Actions
#1

Updated by Chris topher almost 12 years ago

This is the same kind of problem as #21227, but here not for a group of modules, but for a single one.

Hiding the module, if it is empty, would be in line with the behaviour after applying #21227. That should be the way to go.

#2

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3

Updated by Michael Schams over 8 years ago

Yes, the issue still exists in TYPO3 CMS 6.0.4. Tested with the a fresh Introduction Package.

How to reproduce (same as above, but 6.0 specific):

- admin BE login
- go to Extension Manager
- under "Manage extensions", type "func" (this displays the sysext in question)
- deactivate the extensions listed above (in the correct order)
- go to "Web>Functions" and select any page in the page tree
- you get an empty right content area (which looks like an error)

See attached screenshots:

screenshot0001-typo3-6.0.x.png
screenshot0002-typo3-6.0.x.png

#5

Updated by Alexander Opitz over 8 years ago

  • Status changed from Needs Feedback to New
#6

Updated by Michael Schams over 8 years ago

I just had the chance to test this on a fresh TYPO3 CMS 6.1.0 Introduction Package instance: same issue.

#7

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35730

#8

Updated by Gerrit Code Review almost 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35730

#9

Updated by Gerrit Code Review almost 7 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35730

#10

Updated by Gerrit Code Review almost 7 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35730

#11

Updated by Gerrit Code Review almost 7 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35730

#12

Updated by Gerrit Code Review almost 7 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35730

#13

Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35739

#14

Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35739

#15

Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35746

#16

Updated by Wouter Wolters almost 7 years ago

  • Status changed from Under Review to Resolved
  • Is Regression set to No
#17

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF