Bug #24804

Moving Elements with Translations in workspaces

Added by Graham Solomon over 10 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2011-01-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We have a website with one alternative language, when in a workspace if you move a default language element then the alternative language version of the element appears on the default language page.

I am using TYPO3 4.5 RC2 this should be easily reproducible.

1. Create a page with at least 2 content elements
2. Localise the page
3. From within a workspace move one of the elements up/down the page
4. The element will be moved as expected, but the alternative language version will appear with the default language elements

I would really appreciate it if this could be fixed for 4.5, we make extensive use of workspaces and will not be able to upgrade whilst this bug is unfixed, this must also be an issue for others using workspaces on a multilingual website?

Kind Regards,
Graham Solomon

(issue imported from #M17304)


Related issues

Related to TYPO3 Core - Bug #16845: Incorrect values of colPos, sys_language_uid and sorting after moving records in web > listClosedStanislas Rolland2007-01-09

Actions
Is duplicate of TYPO3 Core - Bug #21628: Error during record up and down move in WorkspaceClosed2009-11-20

Actions
#1

Updated by Tolleiv Nietsch over 10 years ago

Sounds reasonable, I'm going to have a look but i doubt that we have a stable version ready for 4.5.0

#2

Updated by Graham Solomon over 10 years ago

Hi Tolleiv,

Thanks for looking at this we appreciate it. It's not a big deal if it doesn't make it ready for 4.5 but if there could be a patch within the next few weeks that would be great.

Graham

#3

Updated by Graham Solomon over 10 years ago

FYI there is a duplicate issue for this 0012686.

#4

Updated by Tolleiv Nietsch over 10 years ago

Ok so this is (just) page & list module specific right?

#5

Updated by Graham Solomon over 10 years ago

Yes I can't think of anywhere else it is possible to reorder content elements.

#6

Updated by Tolleiv Nietsch over 10 years ago

Ok - just reviewed it and I can confirm it. But the risk to break sth. right before the release is imho too big. And this bug was also known for a long time and wasn't introduce with 4.5, therefore I'd prefer to propose a solid solution for one of the next patch level releases of 4.5

#7

Updated by Graham Solomon over 10 years ago

I understand it is a bit risky at this stage of the release cycle to fix this, would be fine to fix in 4.5.1.

#8

Updated by Stanislas Rolland over 10 years ago

Please test patch attached to issue #0004759 with TYPO3 4.5 or current trunk.

#9

Updated by Graham Solomon over 10 years ago

I can still reproduce this, tested against v4.5.2

#10

Updated by Graham Solomon over 10 years ago

I have just tried applying the following patch to my 4.5.2 installation (I assume this is the latest fix):
typo3core_bugfix_4759_trunk_v2.patch [^] (3,500 bytes) 26.01.11 17:43

When moving an element of the default language the localised version no longer appears on the default language page - however the localised version does not follow the default elements position and remains where it was. Not sure if this is intended, it could cause permissions issues I suppose if a BE user has access to the default language only and is inadvertently moving around localisations when reordering default content, some people may want the localisations to stay in their original position - for the websites I manage though it would be great if the sorting of localisations was 'synced' with that of the default language, perhaps this behaviour could be configurable?

The patch has also introduced a new bug, if I move a default language element in any column other than "Normal", for example moving a content up/down in the right column, it moves across to the normal column.

#11

Updated by Administrator Admin over 10 years ago

I can confirm what Graham has observed. This is a rather serious issue for sites using workspaces and using multiple languages.

#12

Updated by Graham Solomon almost 10 years ago

Can someone tell me how we might sponsor this bug and how much it would cost to have it fixed please?

Many Thanks,
Graham Solomon

#13

Updated by Thomas almost 10 years ago

This bug – that renders the usage of the WS useless, since this behavior migth lead to fatal errors – is really four years old?

I am afraid, that this is the tip of the iceberg only. We would love to use workspaces, but came to the conclusion that we can't. And being a developer myself and looking at the current data model (tt_content, pages, pages_language_overlay) I doubt this will ever work flawlessly.

Our hopes got out to the workspaces of Phoenix and the data handling of FLOW3!

#14

Updated by Alexander Opitz about 8 years ago

  • Status changed from Accepted to Closed

No feedback for over 90 days.

Also available in: Atom PDF