Bug #16845

Incorrect values of colPos, sys_language_uid and sorting after moving records in web > list

Added by Thomas Oppelt almost 15 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2007-01-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

sys_language_uid becomes 0 when sorting tt_content record manually in web > list while localization view is disabled!
l18_parent stays right just sys_language_uid gets lost.

(issue imported from #M4759)


Files

0004759.patch (2.03 KB) 0004759.patch Administrator Admin, 2007-01-10 20:03
typo3core_bugfix_4759_trunk_v2.patch (3.42 KB) typo3core_bugfix_4759_trunk_v2.patch Administrator Admin, 2011-01-26 17:43
typo3core_bugfix_4759_typo3_4-4_v2.patch (3.38 KB) typo3core_bugfix_4759_typo3_4-4_v2.patch Administrator Admin, 2011-01-26 17:43
typo3core_bugfix_4759_typo3_4-3_v2.patch (3.38 KB) typo3core_bugfix_4759_typo3_4-3_v2.patch Administrator Admin, 2011-02-03 06:28

Related issues

Related to TYPO3 Core - Bug #18142: colPos gets overwritten by colPos value of a copy/pasted content element when sorting in web > listClosedChristian Kuhn2008-02-06

Actions
Related to TYPO3 Core - Bug #15688: no sorting in "Localization view" (with own records)Closed2006-02-20

Actions
Related to TYPO3 Core - Bug #14873: CE jumps from right to normal when moved in list modeClosed2005-07-21

Actions
Related to TYPO3 Core - Bug #22869: wrong sorting of translated CEClosed2010-06-12

Actions
Related to TYPO3 Core - Bug #22949: Sorting Content Elements with translations doesn't work exactlyClosed2010-06-21

Actions
Related to TYPO3 Core - Bug #19311: language changes when switching position is web>pageClosed2008-09-10

Actions
Related to TYPO3 Core - Bug #24804: Moving Elements with Translations in workspacesClosedTolleiv Nietsch2011-01-25

Actions
Related to TYPO3 Core - Bug #21628: Error during record up and down move in WorkspaceClosed2009-11-20

Actions
Related to TYPO3 Core - Bug #24314: Moving Content Elements up and down with translationClosed2010-12-09

Actions
Related to TYPO3 Core - Bug #59901: Move records in list module kills sys_language_uidClosed2014-06-26

Actions
Has duplicate TYPO3 Core - Bug #16955: Moving content element changes language settingClosedOliver Hader2007-02-08

Actions
Has duplicate TYPO3 Core - Bug #25866: Can´t move or delete records in draft workspaceClosedDani no-lastname-given2011-04-10

Actions
Is duplicate of TYPO3 Core - Bug #30469: Sorting of localized tt_content elements is wrong after copyingClosedStanislas Rolland2011-09-30

Actions
Has duplicate TYPO3 Core - Bug #12328: Reordering localized content causes translation to display under default languageClosed2011-01-17

Actions
#1

Updated by Oliver Hader almost 15 years ago

I can confirm this. But it only occours on sorting using the negative id-variant so that the cmd-Array of TCEmain looks like this:

$cmd['tt_content']['85']['move'] = -86;

#2

Updated by Oliver Hader almost 15 years ago

I just steped over it...
In TCEmain there's a method called fixCopyAfterDuplFields
The strange thing is, that this method is also called while moving records (sorting is handled by TCEmain as moving on the same page). The function copies some values from one of the records to be sorted to the other one. So the sys_language_uid got overwritten and resulted in "0", the value of the other record.

Strange!

The patch removes the function call from move-commands (commented out). So, just play around with every possible call and action in the TYPO3 Backend according to sort, copy, move, edit, delete and we'll see if removing the function call helps.

#3

Updated by Aulis Telle over 14 years ago

I played with the sorting in the BE and moved some translated and the corresponding original items around. What I noticed was, that the sys_language_uid was only changed, when the sorting field was also changed. That is, with "localization view" disabled, when I move a content element with sys_language_uid==1 past elements with sys_language_uid != 1 everything is ok. If I move it past an element with the same sys_language_uid, sorting is changed and the sys_language_uid becomes that of the corresponding translation. I tested this only for one language, i.e. I have a default language 0 and a translation language 1.

I hope that helps to find the bug in the code.

#4

Updated by Stanislas Rolland almost 11 years ago

Please test attached patch.

#5

Updated by Felix Buenemann almost 11 years ago

(Also commented on core list:)
This fixes for me the problem described in #19311, that when moving default language CEs, the dependent translated CEs loose their language assignment when in draft workspace. I'm however now seeing entries in live workspace, after moving elements in the draft version wihtout publishing, like:

[MOVE-TO PLACEHOLDER for # 1560, WS#-1]
[MOVE-TO PLACEHOLDER for # 1559, WS#-1]

So I think the patch needs fixes for working with workspaces.

Also there seems to be an off-by-one problem when moving the related translated CEs (both in live and draf workspace):

Lets say I move def language CE from pos 3 to pos 2, then the translated CE will move to pos 3 to pos 1.
If I move def from 3 to 4, tranlsated will stay at pos 3.
If I move def from 3 to 5, trans will move from 3 to 4.

Tested on 4.4.4 with typo3core_bugfix_4759_typo3_4-4.patch.

#6

Updated by Felix Buenemann almost 11 years ago

Please add relationship to #19311

#7

Updated by Stanislas Rolland over 10 years ago

Uploaded second version of patch fixing the order of moved language records.

#8

Updated by Stanislas Rolland over 10 years ago

@Felix: I am unable to reproduce this placeholders issue with current trunk (TYPO3 4.5.0).

I think this should have been fixed in 4.4.6 (see #0016005).

#9

Updated by Felix Buenemann over 10 years ago

@Stanislas: Yes, the placeholder issue is fixed on 4.4.4 after applying ws_placeholders.patch

However the Off-By-One error described by me is still not fixed in typo3core_bugfix_4759_typo3_4-4_v2.patch. Tested on 4.4.4 and 4.4.6.

#10

Updated by Dani no-lastname-given over 10 years ago

Patch works also in 4.5.2. I only get the Button "copy default content elements [1]" in the translation column if I move records in the default column. If i click this button I get this warning: 1: [newlog()] Localization failed; There already was a localization for this language of the record! How can I remove the Button?

#11

Updated by Dani no-lastname-given over 10 years ago

and also it only works in the normal column. if I want to move records of the left column they jump into the normal column now.

#12

Updated by Oliver Hader over 10 years ago

  • Target version deleted (0)

Can you please tell in which version this occurs on your side and how to reproduce it step-by-step. Since localization and workspaces are used, it might be really tricky to find the real problem here deep down in t3lib_TCEmain. Thanks in advance!

#13

Updated by Felix Buenemann over 10 years ago

I've tested typo3core_bugfix_4759_trunk_v2.patch against vanilla 4.5.2 and the off-by-one error when moving records in web -> page module -> language view with translations is still there.

Eg. given these records:

DE 1 | EN 1
DE 2 | EN 2
DE 3 | EN 3

Now go ahead, and move DE 3 one position up and you end up with:

DE 1 | EN 3
DE 3 | EN 1
DE 2 | EN 2

If you move DE 3 back one position down you get:

DE 1 | EN 1
DE 2 | EN 3
DE 3 | EN 2

So it stays offset by one.

It doesn't matter wether you do this in live or draft workspace.

#14

Updated by Dani no-lastname-given over 10 years ago

I use Typo3 4.5.2 with Workspaceversion 4.5.1. Default Language is German and also I have an English translation. Layout: 3 Columns (left, normal, right)
Moving records without this patch in Draft-Workspace:

DE 1 | EN 1
DE 2 | EN 2
DE 3 | EN 3

Move DE 3 one position up you get (column1):

DE 1 | EN 1
EN 3 | EN 2
DE 3 |
DE 2 |

Using the Patch typo3core_bugfix_4759_typo3_4-4_v2.patch

DE 1 col1 | EN 1 col2
DE 2 col1 | EN 2 col2
DE 3 col1 | EN 3 col2

DE 1 col1 | EN 1 col2
DE 2 col1 | EN 2 col2
DE 3 col1 | EN 3 col2

than moving DE 3 up in column1:

DE 1 col1 | EN 1 col1
DE 2 col1 | EN 2 col1

DE 3 col1 | EN 3 col1
DE 1 col2 | EN 1 col2
DE 2 col2 | EN 2 col2
DE 3 col2 | EN 3 col2

Moving records of the english Draft-Workspace works in the normal colum - moving records in the left or right column, they jump into the normal column!
Moving records in Live Workspace works but the english translation move also if I move the german record but if i move the english record the german translation don´t move! After Moving the german record up the english translation record follow but if I move the german record back on the startingposition the english one don´t follow.

#15

Updated by Stanislas Rolland over 9 years ago

Felix Buenemann wrote:

I've tested typo3core_bugfix_4759_trunk_v2.patch against vanilla 4.5.2 and the off-by-one error when moving records in web -> page module -> language view with translations is still there.

Eg. given these records:
[...]

Now go ahead, and move DE 3 one position up and you end up with:
[...]

If you move DE 3 back one position down you get:
[...]

So it stays offset by one.

It doesn't matter wether you do this in live or draft workspace.

This problem is fixed by this change: https://review.typo3.org/8679

Please test it.

#16

Updated by Stanislas Rolland over 9 years ago

Dani wrote:

I use Typo3 4.5.2 with Workspaceversion 4.5.1. Default Language is German and also I have an English translation. Layout: 3 Columns (left, normal, right)
Moving records without this patch in Draft-Workspace:

DE 1 | EN 1
DE 2 | EN 2
DE 3 | EN 3

Move DE 3 one position up you get (column1):

DE 1 | EN 1
EN 3 | EN 2
DE 3 |
DE 2 |

Using the Patch typo3core_bugfix_4759_typo3_4-4_v2.patch

DE 1 col1 | EN 1 col2
DE 2 col1 | EN 2 col2
DE 3 col1 | EN 3 col2

DE 1 col1 | EN 1 col2
DE 2 col1 | EN 2 col2
DE 3 col1 | EN 3 col2

than moving DE 3 up in column1:

DE 1 col1 | EN 1 col1
DE 2 col1 | EN 2 col1

DE 3 col1 | EN 3 col1
DE 1 col2 | EN 1 col2
DE 2 col2 | EN 2 col2
DE 3 col2 | EN 3 col2

Moving records of the english Draft-Workspace works in the normal colum - moving records in the left or right column, they jump into the normal column!
Moving records in Live Workspace works but the english translation move also if I move the german record but if i move the english record the german translation don´t move! After Moving the german record up the english translation record follow but if I move the german record back on the startingposition the english one don´t follow.

This behaviour is also fixed by this change: https://review.typo3.org/8679

Please test it.

#17

Updated by Stanislas Rolland about 9 years ago

  • Status changed from Accepted to Resolved

No feedback for a long time...

I think is is fixed in current master and stable releases.

#18

Updated by Tobias Gaertner over 7 years ago

its not fixed in 4.5.30 !!!!

#19

Updated by Thorsten Kahler over 7 years ago

  • Is Regression set to No

Tobias Gaertner wrote:

its not fixed in 4.5.30 !!!!

What exactly is not fixed in 4.5.30 (btw. 4.5.32 is current patch level release)? Is it the original issue (language of record is lost when moving records in List module)? Or any of the other bugs mentioned in this thread? If the latter, please search for an existing ticket or create a new one.

Just for the record: IMHO the original "bug" is an UX issue: it's simply undefined where to move a translated record if the localization view is deactivated.

#20

Updated by Tobias Gaertner over 7 years ago

Thnx.

Since I change order of records and translate them the order of translation is messed up in backend.
I think the related bug for my problem is Bug #25254

#21

Updated by Christian Hernmarck over 7 years ago

I don't know exactly what was fixed here - but there is still a problem when moving content-elements in list view and having several columns (colPos) and languages (sys_language_uid).

See #59901

(Typo3 4.5.35 and TYPO3 6.2)

#22

Updated by Tymoteusz Motylewski over 3 years ago

  • Related to Bug #59901: Move records in list module kills sys_language_uid added
#23

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF