Task #24840

spritemanager and clear cache

Added by Peter Niederlag almost 10 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-01-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

spritemanager keeps outdated data in 'typo3temp/sprites/zextensions.css'

  • change the TCA of you EXTENSION and change/add/delete any 'iconfile'
  • work in list module (BE)

you have to manually remove 'typo3temp/sprites/zextensions.css' to get the updates effective

Easy solution would be to just remove this file on "clear config cache"

(issue imported from #M17344)


Related issues

Related to TYPO3 Core - Task #70477: Deprecate SpriteIcon classesClosedFrank Naegler2015-10-07

Actions
#1

Updated by Steffen Gebert almost 10 years ago

AFAIK it's triggered on Extension installation. So I fear the answer is: won't fix.
However, I'm not too much into detail of the sprites..

#2

Updated by Peter Niederlag almost 10 years ago

well, if it is cleared on an extension update it is OK, as then only developers are affected that work. ;) I was afraid that even an update via the EM wouldn't catch that update.

Still. it is quite weird to have that (sometimes) outdated data out there without any button to force an update.

#3

Updated by Steffen Gebert almost 10 years ago

Yes, we also need some cache for the compressor to not always recalculate all the CSS file mtimes and so.
Think we'll get a "system cache" or so in 4.6

#4

Updated by Julian Hofmann about 9 years ago

I agree with Peter. I'm missing such a possibility, too.

Maybe, it is triggered on Extension installation or could be cleared/refreshed manually. But in some cases it makes sense to initiate this update via extension code.

For example, EXT:kb_page_icon gives be-users the possibility to add pageicons via page properties. This would be after installing the extension, so any trigger in the extensionmanager would not be called. And forcing a be-user to clear any cache after changing an icon would not be very gentle.

I'm wondering why there is no possibility for calling a method like t3lib_SpriteManager::rebuildCache() on demand.

#5

Updated by Steffen Gebert about 9 years ago

  • Status changed from Closed to Accepted
  • Assignee deleted (Steffen Gebert)
  • Target version deleted (0)
  • TYPO3 Version set to 4.7
#6

Updated by Steffen Ritter almost 9 years ago

  • Tracker changed from Bug to Task
#7

Updated by Elio over 8 years ago

Any update?

A fix to this would be really a big help because this problem arises quite often.

Thanks! Elio

#8

Updated by Georg Ringer almost 6 years ago

  • Status changed from Accepted to Resolved

a system cache is now with 6.2 in place which clears everything. as this needs also time to rebuild everything, this should be really cleared with care!

#9

Updated by Markus Klein almost 6 years ago

  • Status changed from Resolved to Accepted

I have this issue also in 6.2 from time to time. For some reason typo3temp/sprites is not cleared properly and/or the system does not realize the existence of new sprites. Once I can reproduce the issue properly, I'll debug it and try to find out why this is not cleared properly with the system cache clear button or any other button.

#10

Updated by Georg Ringer about 5 years ago

  • Status changed from Accepted to Closed

SpriteManager is deprecated now, therefore I close this issue

Also available in: Atom PDF