Bug #26484

extend to subpages in page properties in access tab does not work correctly

Added by Simon Schaufelberger about 10 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2011-04-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

I have a page structure like this:

-Page
 - Page (access restricted including subpages)
  - Page (x)
 - Login page

now when i call page x directly from the backend without being logged in, i still see the page but not the content. Only if i set the page x also as restriced page (set a usergroup to it), THEN i get a redirect to the login page.

TYPO3 4.5.2


Related issues

Related to TYPO3 Core - Bug #15984: menu.showAccessRestrictedPages doesn't replace link for "include subpages"Accepted2006-04-05

Actions
Related to TYPO3 Core - Bug #78825: Wrong pid determination when opening a nested access restriced pageNeeds Feedback2016-11-28

Actions
#1

Updated by Andreas Wolf over 9 years ago

  • Category set to Content Rendering
  • Status changed from New to Needs Feedback
  • Complexity set to medium

Is this still valid with the latest core version?

#2

Updated by Simon Schaufelberger over 9 years ago

At the moment i cannot even reproduce it again with 4.5.2. It was one of our plenty websites... Maybe it has to do with the pageNotFound_handling settings

#3

Updated by Stephan Großberndt over 8 years ago

I have a problem that is related, if its not the same:

- TYPO3 4.5.22 (default settings for page not found)

$TYPO3_CONF_VARS['FE']['pageNotFound_handling'] = ''

- realurl 1.12.3 (default settings for page not found)

$TYPO3_CONF_VARS['EXTCONF']['realurl']['_DEFAULT'] = array(
    'init' => array(
        'enableCHashCache' => 1,
        'enableUrlDecodeCache' => 1,
        'enableUrlEncodeCache' => 1,
        'appendMissingSlash' => 'ifNotFile',
    ),

I have a page structure like this:

root
 - homepage
  - sysfolder
   - access restricted page (including sublevels)
    - page X

When you re-access page X after having been logged out, TYPO3 serves an empty page - which is the content of sysfolder! (checked by dumping $TSFE->id in index_ts.php).

As far as I can figure it out: TYPO3 sees the access restriction and starts walking the tree to root until it finds a page that is not access restricted - but does not take into account that sysfolders do not have content to display and therefore should not be served.

#4

Updated by Maarten Mandemaker about 8 years ago

Bug confirmed (TYPO3 6.0.2)

Redirection to (login)page only works when accessing a page which has explicit access rights. It does not work when the page inherits the access conditions from a higher level (extend to subpages checkbox).

#5

Updated by Jigal van Hemert almost 8 years ago

  • Category deleted (Content Rendering)
  • Status changed from Needs Feedback to New
#6

Updated by Philipp Gampe almost 8 years ago

  • Category set to Frontend
  • Status changed from New to Accepted
#7

Updated by Alex no-lastname-given about 7 years ago

Bug exists in TYPO3 6.1.7 also

#8

Updated by Simon Schaufelberger about 7 years ago

Can anybody come up with a solution? I guess thats not really easy to fix...

#9

Updated by Dimitri König about 6 years ago

Bug still exists in 6.2.12. I'm on it...

#10

Updated by Riny van Tiggelen over 5 years ago

Problem still exists in 6.2.15. Is there any news on this since the bug exists since 4.5?

#11

Updated by Riccardo De Contardi about 4 years ago

can this be considered a duplicate of #15984 ? See https://forge.typo3.org/issues/15984#note-15

#12

Updated by Riccardo De Contardi about 4 years ago

  • Related to Bug #15984: menu.showAccessRestrictedPages doesn't replace link for "include subpages" added
#13

Updated by Riccardo De Contardi about 4 years ago

  • Related to Bug #78825: Wrong pid determination when opening a nested access restriced page added
#14

Updated by Riccardo De Contardi about 4 years ago

  • Related to Bug #15984: menu.showAccessRestrictedPages doesn't replace link for "include subpages" added
#15

Updated by Riccardo De Contardi about 4 years ago

  • Related to deleted (Bug #15984: menu.showAccessRestrictedPages doesn't replace link for "include subpages")
#18

Updated by Riccardo De Contardi about 1 year ago

On version 9.5.14 and 10.4.0-dev (latest master), if I try to access a subpage of a restricted page (*) directly from the backend, I get a "page not found" error (403 If I am not wrong).

(*) Note: the restricted page has

- is restricted
-has "extend to subpages" checked

#19

Updated by Susanne Moog about 1 year ago

  • Status changed from Accepted to Closed

As verified by Riccardo this is fixed in newer versions.

Also available in: Atom PDF