Bug #26612

Preview does not include L parameter if not default language

Added by Simon Schaufelberger over 8 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2011-05-04
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Using T3 4.5.2 and no templavoila, i have the problem that the preview icon link is not correct.
I am in my workspace and in page module. I switch to another language via the dropdown in the top toolbar.

My link looks like this:

http://example.com/typo3/mod.php?id=14
&tx_workspaces_web_workspacesworkspaces[action]=index
&tx_workspaces_web_workspacesworkspaces[controller]=Tx_Workspaces_Controller_PreviewController
&tx_workspaces_web_workspacesworkspaces[controller]=Preview
&M=web_WorkspacesWorkspaces
&id=14

Well, id is included twice but no L parameter. SOMEHOW this works with templavoila, i have no idea why...


Related issues

Related to TYPO3 Core - Bug #12970: Generate Workspace Preview Link should honor options.view.languageOrder Closed 2011-02-11
Related to TYPO3 Core - Bug #20852: Can create preview links only for the default language of a page Closed 2009-08-07

Associated revisions

Revision 1f91a3d3 (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Preview does not include L parameter on localization

The workspace module offers a way to preview accordant records
in the frontend. However, the L parameters is missing if dealing
with localized records.

The language needs to be determined from the version record, not
from the live record (which might be a placeholder as well).
Besides that, the L parameter needs to be provided as additional
GET parameter since it cannot be determined anymore later during
processing in t3lib_BEfunc::viewOnClick().

Change-Id: I97083cabce33c7f23a4f20687cfc81865cb8f68c
Fixes: #26612
Releases: 4.5, 4.6, 4.7, 6.0, 6.1
Reviewed-on: https://review.typo3.org/17278
Reviewed-by: Stefan Neufeind
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision a1187166 (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Preview does not include L parameter on localization

The workspace module offers a way to preview accordant records
in the frontend. However, the L parameters is missing if dealing
with localized records.

The language needs to be determined from the version record, not
from the live record (which might be a placeholder as well).
Besides that, the L parameter needs to be provided as additional
GET parameter since it cannot be determined anymore later during
processing in t3lib_BEfunc::viewOnClick().

Change-Id: I97083cabce33c7f23a4f20687cfc81865cb8f68c
Fixes: #26612
Releases: 4.5, 4.6, 4.7, 6.0, 6.1
Reviewed-on: https://review.typo3.org/17347
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision d8abc9af (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Preview does not include L parameter on localization

The workspace module offers a way to preview accordant records
in the frontend. However, the L parameters is missing if dealing
with localized records.

The language needs to be determined from the version record, not
from the live record (which might be a placeholder as well).
Besides that, the L parameter needs to be provided as additional
GET parameter since it cannot be determined anymore later during
processing in t3lib_BEfunc::viewOnClick().

Change-Id: I97083cabce33c7f23a4f20687cfc81865cb8f68c
Fixes: #26612
Releases: 4.5, 4.6, 4.7, 6.0, 6.1
Reviewed-on: https://review.typo3.org/17346
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 334732e9 (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Preview does not include L parameter on localization

The workspace module offers a way to preview accordant records
in the frontend. However, the L parameters is missing if dealing
with localized records.

The language needs to be determined from the version record, not
from the live record (which might be a placeholder as well).
Besides that, the L parameter needs to be provided as additional
GET parameter since it cannot be determined anymore later during
processing in t3lib_BEfunc::viewOnClick().

Change-Id: I97083cabce33c7f23a4f20687cfc81865cb8f68c
Fixes: #26612
Releases: 4.5, 4.6, 4.7, 6.0, 6.1
Reviewed-on: https://review.typo3.org/17277
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision a9f014b0 (diff)
Added by Oliver Hader almost 7 years ago

[BUGFIX] Preview does not include L parameter on localization

The workspace module offers a way to preview accordant records
in the frontend. However, the L parameters is missing if dealing
with localized records.

The language needs to be determined from the version record, not
from the live record (which might be a placeholder as well).
Besides that, the L parameter needs to be provided as additional
GET parameter since it cannot be determined anymore later during
processing in t3lib_BEfunc::viewOnClick().

Change-Id: I97083cabce33c7f23a4f20687cfc81865cb8f68c
Fixes: #26612
Releases: 4.5, 4.6, 4.7, 6.0, 6.1
Reviewed-on: https://review.typo3.org/17278
Reviewed-by: Stefan Neufeind
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader
Reviewed-on: https://review.typo3.org/17349

History

#1 Updated by Oliver Hader over 8 years ago

  • Status changed from New to Accepted
  • Assignee set to Oliver Hader
  • TYPO3 Version set to 4.5

#2 Updated by Stefan Neufeind about 8 years ago

code-path for further investigations:
Classes/Service/Workspaces.php, generateWorkspaceSplittedPreviewLink()
which calls the UriBuilder from Extbase:
Classes/MVC/Web/Routing/UriBuilder.php

It seems that the UriBuilder already generates the id=... at beginning of this link and we could avoid adding it later. Also the controller-parameter is generated in the first place and then manually added again (second parameter, probably overwriting the first one) in the URL mentioned.

The language-parameter is added in
t3lib/class.t3lib_befunc.php, viewOnClick()
But for some reason it doesn't add the L-parameter there ...

The $viewScript-parameter itself is created in the preProcess-hook called from viewOnClick() and implemented in the workspace-package.

#3 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch 4.5 has been pushed to the review server.
It is available at https://review.typo3.org/17277

#4 Updated by Gerrit Code Review almost 7 years ago

Patch set 2 for branch 4.5 has been pushed to the review server.
It is available at https://review.typo3.org/17277

#5 Updated by Gerrit Code Review almost 7 years ago

Patch set 3 for branch 4.5 has been pushed to the review server.
It is available at https://review.typo3.org/17277

#6 Updated by Gerrit Code Review almost 7 years ago

Patch set 4 for branch 4.5 has been pushed to the review server.
It is available at https://review.typo3.org/17277

#7 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/17278

#8 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch 4.6 has been pushed to the review server.
It is available at https://review.typo3.org/17346

#9 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch workspaces_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17347

#10 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch workspaces_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/17349

#11 Updated by Oliver Hader almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:c6d19bc0e7417ff2bce7da587d812a7daa7a3473.

#12 Updated by Michael Stucki almost 6 years ago

  • Category set to Workspaces

#13 Updated by Michael Stucki almost 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#14 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF