Bug #26709

TCA tt_content - l18n_parent field missing

Added by Daniel Alder about 10 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2011-05-09
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I think around line 1968 in tbl_tt_content.php (sysext 'cms') is the l18n_parent field missing.
The corresponding label is missing too. See locallang_ttc.xml.

Now:

'general' => array(
    'showitem' => 'CType;LLL:EXT:cms/locallang_ttc.xml:CType_formlabel, colPos;LLL:EXT:cms/locallang_ttc.xml:colPos_formlabel, sys_language_uid;LLL:EXT:cms/locallang_ttc.xml:sys_language_uid_formlabel',
    'canNotCollapse' => 1,
),


Files

demo.diff (1.91 KB) demo.diff Daniel Alder, 2011-05-10 09:06

Related issues

Related to TYPO3 Core - Feature #23766: Implement new layout and labels for tt_content as result of T3UXW09ClosedSteffen Kamper2010-10-17

Actions
#1

Updated by Daniel Alder about 10 years ago

Possible solution

#2

Updated by Peter Kraume about 10 years ago

Quick workaround: create a new extension and put this into ext_tables.php:

t3lib_extMgm::addToAllTCAtypes('tt_content','l18n_parent');

#3

Updated by Markus Klein about 10 years ago

Should be enough to add this line to typo3conf/extTables.php.

#4

Updated by Thomas Deinhamer about 10 years ago

  • Target version set to 4.5.4

It seems that the l18n_parent field was forgotten,
maybe because if it is shown, it will probably explode
the layout as it can get very long for text content elements.

Probably this needs some adjustments, but at present
there is no default setting in the TCA to render this
select field with acceptable output.

The only possible way to limit the width of the select field
for now, would be to write a custom userfunc for the field.

You can edit the l18n_parent in the list view anyway,
but for normal editors no chance, they can't reference
new created elements (no-copy) to original contents.

I think this should be fixed in the next 4.5 release too.

My temporary bugfix is was to overwrite the TCA in the
ext_tables.php file inside a custom extension; I added
"--linebreak--, l18n_parent" at the end:

$TCA['tt_content']['palettes']['general']['showitem'] = 'CType;LLL:EXT:cms/locallang_ttc.xml:CType_formlabel, colPos;LLL:EXT:cms/locallang_ttc.xml:colPos_formlabel, sys_language_uid;LLL:EXT:cms/locallang_ttc.xml:sys_language_uid_formlabel, --linebreak--, l18n_parent';

#5

Updated by Oliver Hader almost 10 years ago

  • Target version changed from 4.5.4 to 4.5.6
#6

Updated by Chris topher over 9 years ago

  • Target version changed from 4.5.6 to 4.5.8
#7

Updated by Ernesto Baschny over 9 years ago

  • Target version changed from 4.5.8 to 4.5.12
#8

Updated by Alexander Bigga over 9 years ago

Markus Klein wrote:

Should be enough to add this line to typo3conf/extTables.php.

That's what I've done and I get a new tab where I can select the parent again.

That's really necessary because not all editors use the "copy from default" button :-(

#9

Updated by Philipp Gampe almost 8 years ago

  • Category set to Backend User Interface
  • Status changed from New to Accepted
  • Target version deleted (4.5.12)

Someone willing to write a patch for this and to push it to gerrit? http://wiki.typo3.org/CWT

#10

Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/29054

#11

Updated by Alexander Bigga about 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#12

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF