Bug #28358

New update function does not warn prominently about locally changed files

Added by Björn Pedersen over 10 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2011-07-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

The old update module marked all extensions with local changes in the update listing.
This is missing in the new EM, which just overwrites without warning.


Related issues

Related to TYPO3 Core - Feature #20664: When updating an extension, archive the old versionClosed2009-06-24

Actions
Related to TYPO3 Core - Bug #63898: update function does not warn prominently about locally changed filesClosed2014-12-15

Actions
#1

Updated by Tolleiv Nietsch over 10 years ago

  • Complexity set to medium
#2

Updated by Steffen Gebert over 10 years ago

  • Priority changed from Must have to Should have
#3

Updated by Helmut Hummel over 10 years ago

  • Target version set to 4.6.0-RC1
#4

Updated by Xavier Perseguers over 10 years ago

  • Target version changed from 4.6.0-RC1 to 4.6.0
#5

Updated by Chris topher about 10 years ago

  • Target version changed from 4.6.0 to 4.6.1
#6

Updated by Xavier Perseguers about 10 years ago

  • Target version deleted (4.6.1)
#7

Updated by Alexander Opitz about 7 years ago

  • Status changed from New to Closed
  • Is Regression set to No

As this functionality is removed since 6.0 and we are moving onwards to use composer, I close this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#8

Updated by Stefan Busemann about 7 years ago

Yes, but using composer does not solve the issue of locally changed files.

For an administrator it should be visible in EM:
  • if a extension was changed locally
  • warn before update to a newer version

an alternative could be #20664 - to archive older versions of extensions while updating via EM

#9

Updated by Stefan Busemann about 7 years ago

So I suggest to reopen this ticket

Also available in: Atom PDF