Bug #29033

CardLayout: Switching between list and page while working leads to inconsistent states

Added by Susanne Moog almost 11 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2011-08-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Hey,

a real problem for me when working with the card layout is that it does not update the content frame when switching modules. Consider the following scenario:

I have a page with lots of content elements that need to be deleted. I first look at the page from the page module and realize it's too much content to delete there, so I switch to list module and delete everything at once. When then switching back to the page module I again see the content on the page which is slightly irritating - but it actually gets worse. There is no reload button, so I use the "reload frame" from my browser. Now the page module displays an even older state - it very much looks like a really bad cache problem. Up until now I did not manage to get the page module to show the real state again.

We definitely need to fix this behavior - I don't want to explain that to my editors ;)


Related issues

Related to TYPO3 Core - Task #30645: Revert "[FEATURE] Speed-up Backend with CardLayout"ClosedXavier Perseguers2011-10-08

Actions
#1

Updated by Jigal van Hemert almost 11 years ago

See http://lists.typo3.org/pipermail/typo3-project-v4/2011-August/002765.html for a discussion in the TYPO3-v4 list about this.
Maybe it's useful to add any opinions there (not too many responses)?

#2

Updated by Xavier Perseguers almost 11 years ago

  • Target version changed from 4.6.0-beta2 to 4.6.0-beta3
#3

Updated by Oliver Hader almost 11 years ago

  • Target version changed from 4.6.0-beta3 to 4.6.0-RC1
#4

Updated by Xavier Perseguers over 10 years ago

  • Priority changed from Must have to Should have
  • Target version changed from 4.6.0-RC1 to 4.7.0
#5

Updated by Stanislas Rolland over 10 years ago

I think this is fixed in the new implementation of the card layout. Am I right?

#6

Updated by Stanislas Rolland over 10 years ago

  • Category set to Backend User Interface
#7

Updated by Steffen Gebert over 10 years ago

  • Status changed from New to Needs Feedback
#8

Updated by Steffen Ritter over 10 years ago

  • Target version changed from 4.7.0 to 4.7.0-beta2
#9

Updated by Steffen Ritter over 10 years ago

  • Status changed from Needs Feedback to Rejected
  • Target version deleted (4.7.0-beta2)

not needed anymore, no cardLayout present

Also available in: Atom PDF