Bug #29696

section_frame in listview displays wrong label

Added by Christian Knuth over 10 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2011-09-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

when renaming the labels for borders (input name = section_frame) via TSconfig, you still have the wrong / old labels in the full listview.


Files


Related issues

Related to TYPO3 Core - Bug #16463: TCEFORM altLabels & addItems CType doesn't change Page-Modul CE LabelsClosed2006-08-13

Actions
Related to TYPO3 Core - Feature #39327: Function to get correct item label including TsConfig valueClosedGeorg Ringer2012-07-27

Actions
Related to TYPO3 Core - Bug #64163: BackendUtility::getProcessedValue does not evaluate foreign_table_whereAccepted2015-01-07

Actions
#1

Updated by Jo Hasenau over 10 years ago

  • Project changed from 1180 to TYPO3 Core
  • Priority changed from Should have to Must have

This is definitely a bug, but it has nothing to do with the modernbe extension aka Grid View.

#2

Updated by Tobias Liebig over 10 years ago

  • Priority changed from Must have to Should have
  • Complexity set to medium
  • TYPO3 Version set to 4.5

i can confirm this issue, using the IntroductionPackage. But it seems to be okay in 4.4.

Looks like the list module does not respect the altLabels from Page TSConfig.

"class.db_list_extra.inc" method "renderListRow" might be to be a good starting point for debugging.

#3

Updated by Marcus Schwemer about 10 years ago

I can confirm this issue too.

I would prefer to change this to a "must have" because using backend layout with more then the predefined 4 columns, the labels for "colPos > 3" will be empty. For the rest it is "left, normal, right, border".

#4

Updated by Wouter Wolters about 7 years ago

  • Status changed from New to Needs Feedback
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

#5

Updated by Markus Klein about 7 years ago

  • Category set to Backend User Interface
  • Status changed from Needs Feedback to Accepted
  • Priority changed from Should have to Must have
  • Target version set to next-patchlevel

Confirmed for 7.1 master

#6

Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#7

Updated by Gerrit Code Review about 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#8

Updated by Gerrit Code Review about 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#9

Updated by Gerrit Code Review about 7 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#10

Updated by Gerrit Code Review about 7 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#11

Updated by Mathias Schreiber about 7 years ago

  • Target version changed from next-patchlevel to 7.4 (Backend)
#12

Updated by Gerrit Code Review almost 7 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#13

Updated by Markus Klein almost 7 years ago

  • Sprint Focus set to Remote Sprint
#14

Updated by Markus Klein over 6 years ago

  • Sprint Focus changed from Remote Sprint to On Location Sprint
#15

Updated by Gerrit Code Review over 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#16

Updated by Gerrit Code Review over 6 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#17

Updated by Gerrit Code Review over 6 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#18

Updated by Gerrit Code Review over 6 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35552

#19

Updated by Markus Klein over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#20

Updated by Mathias Schreiber over 6 years ago

  • Sprint Focus deleted (On Location Sprint)
#21

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF