Bug #30352

Bookmarks to pages don't work

Added by Jochen Weiland almost 11 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Category:
Pagetree
Target version:
Start date:
2011-09-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

When setting a bookmark to a page, the bookmark appears in the bookmark list, but does not link to the page bookmarked.
Steps to reproduce:

Go to page A and set a bookmark
Go to page B
Klick on bookmarks and select bookmark of page A -> you will not be redirected to page A

However, bookmarks to content elements work as expected.


Files

30352_jump_backend_beta_fix.patch (545 Bytes) 30352_jump_backend_beta_fix.patch Breaks last visited page restore in some cases Jozef Spisiak, 2012-01-18 21:38
typo3_30352.patch (1.51 KB) typo3_30352.patch Stefan Galinski, 2012-01-26 21:39

Related issues

Related to TYPO3 Core - Bug #34860: Fix for Bug #30352 introduced in 4.5.12 breaks live search resultsClosedStefan Galinski2012-03-14

Actions
Has duplicate TYPO3 Core - Bug #30221: JS Jump function (e.g. for Shortcuts in the Backend) doesn't work reliableClosed2011-09-23

Actions
#1

Updated by Steffen Gebert almost 11 years ago

  • Category changed from Backend User Interface to Pagetree
  • Status changed from New to Accepted
  • Target version deleted (4.5.7)

This seems to be caused by the page tree. The correct page is loaded for a short moment, but as afterwards the page tree is loaded, it sets the content frame to the "current" page (which is the page, on which you have been, not the page, to which the bookmark targets).

It seems like this bug is not present in master, probably due to the CardLayout changes?

Stefan, can you please have a look, whether I'm right?

#2

Updated by Steffen Gebert almost 11 years ago

  • Complexity set to medium
#3

Updated by Klaus Hinum almost 11 years ago

Further Information can be also found in the closed bug
http://forge.typo3.org/issues/30221
And it is still also happening in 4.6

#4

Updated by Klaus Hinum almost 11 years ago

The bug could be related to the EXT JS page tree, as when the page tree won't load (due to timeout issues after re-login e.g.) with the error message:

router
ExtDirect: Invalid Security Token!

the bookmarks (and calls from our plugins to the jump JS function) do work. However, a lot of "Validating the security token of this form has failed. Please reload the form and submit it again." will appear.

#5

Updated by Klaus Hinum over 10 years ago

still present in 4.6.2 and extremely annoying as it affects a lot of plugins in our installation. Any update or target version?

#6

Updated by Steffen Gebert over 10 years ago

It requires an ExtJS expert.. Stefan or Stan..

#7

Updated by Jozef Spisiak over 10 years ago

It's a shame, such bug is hunting here for so long unresolved. So I played a little with javascript and the result is partial fix, by disabling recover of last visited page in one case. Only difference I have found so far is when user logs in and goes to module with page tree, he gets root page opened in main content instead of last visited page (this page is still marked in the page tree). Maybe this change disables last visited page restore in some other cases, however in my opinion its better broken jump function. I was not able to come up with better fix, since my knowledge of ExtJs is poor. Probably the restore state function should detect that jump URL function has been called and as a result of this skip the restore of last visited page.

#8

Updated by Klaus Hinum over 10 years ago

Hi Jozef,

thanks for your fix, seems to work for us - finally the backend is usable again without headaches. If the devs won't fix this properly, I vote to include your patch as it is has a less often happening bug in it.

#9

Updated by Stefan Galinski over 10 years ago

I wrote a less destructive patch for this issue now, but I'am not sure if it works. If someone can give me an affirmation that the patch does it's job without breaking anything else in it's installation I will submit it to Gerrit. Possible issues may be critical so please don't just test the favorites/bookmarks and a call to the page module. The patch can be easily backported to 4.5 and 4.6 so everybody can be happy again. ;-)

BTW: Thanks Steffen for your ranting on twitter 'bout this issue that motivated me enough to fix it. :P

#10

Updated by Stefan Galinski over 10 years ago

  • Assignee set to Stefan Galinski
  • Target version set to 4.5.12
#11

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8785

#12

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8785

#13

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/8829

#14

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/8830

#15

Updated by Stefan Galinski over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#16

Updated by Klaus Hinum over 10 years ago

Just tried the final 4.7.0 and bookmarks indeed do work, but still my own plugins show the wrong behavior with the code
<a href="#" onclick="top.fsMod.recentIds[\'web\']='.$this->id.';
top.fsMod.navFrameHighlightedID[\'web\']=\'pages'.$this->id.'_0\';
top.content.nav_frame.refresh_nav();
top.jump(unescape(\'URL'\'),\'plugin\',\'web\')">Link</a>
Is something wrong with my code (worked before and with the first patch)?

#17

Updated by Stefan Galinski over 10 years ago

Just call top.jump in your onclick event and add the id as last parameter. The latter one isn't used currently in 4.7, but the usage is already integrated inside the master to expand the tree to the wanted page.

BTW: Also you should not use the method "unescape"...

http://www.w3schools.com/jsref/jsref_unescape.asp

#18

Updated by Klaus Hinum over 10 years ago

Hi Stefan,

thanks for the answer. I found the remaining issue, I got a
top.fsMod.recentIds["web"] = '.intval($this->id).';
in the code of my plugin and that invoked a reload of the module. I am not sure if that is wanted.

btw. the Shortcut function in the backend also use "unescape" thats why I was using it.

#19

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF