Bug #32292

Page within a mountpoint using "Show Content from Page" results in 503 header

Added by Patrick Broens almost 10 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Category:
Content Rendering
Target version:
-
Start date:
2011-12-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
A page (A) within a mountpoint using "Show Content from Page" (B) (pages: content_from_pid) results in a 503 header with the message "The requested page didn't have a proper connection to the tree-root!".

When content_from_pid is used, the TSFE for the current object (page A) will be cloned to a temporary object in tslib:TSpagegen (page B). In this temporary object, the page id is set to "page A"->content_from_pid. However, the MP is not changed, and will have the MP of page A.

This results in a TSFE page object (Page B) with the wrong MP (From Page A).

Within this temporary object the rootline will be calculated, which will be empty, because of the wrong MP variable. This triggers the 503 header with the mentioned message.

Solution:
Clear the MP variable in the temporary TSFE object for page B.

Releases:
4.7, 4.6, 4.5


Related issues

Related to TYPO3 Core - Bug #29584: Shortcut to mountpoint results in illegal root treeRejected2011-09-09

Actions
#1

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7071

#2

Updated by Oliver Hader almost 10 years ago

  • Target version changed from 4.7.0-alpha2 to 4.7.0-alpha3
#3

Updated by Steffen Ritter almost 10 years ago

  • Target version changed from 4.7.0-alpha3 to 4.7.0-beta1
#4

Updated by Steffen Ritter over 9 years ago

  • Target version changed from 4.7.0-beta1 to 4.7.0-beta2
#5

Updated by Patrick Broens over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Gerrit Code Review over 9 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/9543

#7

Updated by Patrick Broens over 9 years ago

  • Status changed from Under Review to Resolved
#8

Updated by Marcus Schwemer over 9 years ago

Hi,

I don't know whether I try to test it right. Here is my setup

- Root-Page
-- Page A (this page is of type mountpoint)
---- Page B (this is the page using "Show content from pid")
-- Page C (Content from this page is shown on Page B)

Is this right? Viewing page B in FE should produce an error in a unpatched version:

The requested page didn't have a proper connection to the tree-root!<br /><br />(Illegal Mount Point found in rootline)

The patch should solve this issue.

But it does not. Even in the current trunk I get this message. Because of the latter I am unsure whether my testing setup is correct.

Can you enlighten me?

Thx,
Marcus

#9

Updated by Michael Lang about 9 years ago

I've tested Mountpoints in a clean installation TYPO3 4.7.7 with PHP 5.3 (testversion on Mittwald, there are only 4 pages and one mount point: http://typo3.p179466.webspaceconfig.de/index.php?id=2) there is still the problem: Mount Point > Mounted Page shows me the "Illegal Mount Point found in rootline"
Mount Point -> This Page shows the content of the page and the menu of the "Mount Page".
I've tested this in many installations, it works only with a PHP 5.3.1 Version on an allincl-server.
To have a solution for this bug is important, cause we have a lot of mount points in our website of our university.

Greetings,
Michael

#10

Updated by Oliver Salzburg about 9 years ago

Still happens in 4.7.7 for me

#11

Updated by Lars Messmer - comsolit AG almost 9 years ago

Still happens in 4.7.8 with realurl
without realurl it works fine, so maybe it is a realurl bug?

#12

Updated by Ernesto Baschny over 8 years ago

  • Target version deleted (4.7.0-beta2)
  • TYPO3 Version changed from 4.7 to 4.5

This is now also fixed in 4.5 and will be part of 4.5.28 to be released this week.

If you still have any similar problem (i.e. you have it in 4.7 etc) it is most probably another problem. Please file a new issue for it, specifying some "how to reproduce" steps or describing your environment and your findings.

Thanks!

#13

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF