Bug #33216

CSS Styled Content does not call extensions in "CType: list"

Added by dermueller no-lastname-given about 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Content Rendering
Target version:
-
Start date:
2012-01-16
Due date:
% Done:

0%

TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In static/setup.txt of CSS Styled Content in TYPO3 4.6.3 the complete block for calling old plugins is missing. See line 1513ff. So extensions like tipafriend won't be displayed any more.

If you look at static/4.5/setup.txt, line 1585ff, you see the missing block

20 { # LIST element references (NOT copy of objects!) # THESE are OLD plugins. Modern plugins registers themselves automatically!
3 = CASE
3.key.field = layout
3.0 = < plugin.tt_guest

4 = CASE
4.key.field = layout
4.0 = < plugin.tt_board_list
4.1 = < plugin.tt_board_tree
2 = CASE
2.key.field = layout
2.0 = < plugin.tt_board_tree
5 = CASE
5.key.field = layout
5.0 = < plugin.tt_products
7 = CASE
7.key.field = layout
7.0 = < plugin.tt_calender
8 = CASE
8.key.field = layout
8.0 = < plugin.tt_rating
9 = CASE
9.key.field = layout
9.0 = < plugin.tt_news
11 = CASE
11.key.field = layout
11.0 = < plugin.tipafriend
20 = CASE
20.key.field = layout
20.0 = < plugin.feadmin.fe_users
21 = CASE
21.key.field = layout
21.0 = < plugin.feadmin.dmailsubscription
}

Related issues

Related to Tip-A-Friend - Bug #33386: Tip-A-Friend does not auto-register with CSC Accepted 2012-01-23

History

#1 Updated by Markus Klein about 7 years ago

See https://review.typo3.org/1275.

I'm not sure why this code still exists in 4.5 though

#2 Updated by Jigal van Hemert almost 7 years ago

I think the code should be removed from 4.5 too. Will ask someone involved with the patch Markus mentioned if 4.5 was left out on purpose.

Anyway, the code for the old extensions must not be re-introduced.

#3 Updated by dermueller no-lastname-given almost 7 years ago

OK, I understand that this code that I consider as missing, has been removed by intention for some reason. So, I would be very happy if someone could explain to me what I can use as a substitute for this if I would like to use an "old" extension like tipafriend?

Of course, I can include an old version of the CSC static TS. Which does not seem to be a good idea, because in a brand new TYPO 4.6 installation I do not want to use an old and in parts outdated version of CSC.

I can copy only the missing TS-code-snippet from an old version of CSC, which will work:
tt_content.list {
20 {
11 = CASE
11.key.field = layout
11.0 = < plugin.tipafriend
}
}

But can this really be the solution? Shouldn't there be a smarter way to include those old plugins? I mean, of course, you can pass the ball to the developers and ask them to update the programming of their extensions (like tt_news did, for example). But in case of tipafriend this has obviously not happened since quite some time. So in the meantime, I don't think that it is a good idea to make these plugins unusable. At least the neccessary steps should be documented clearly in some central place like the TYPO3 Wiki. Please correct me, if I am getting something totally wrong here!

#4 Updated by Ernesto Baschny almost 7 years ago

In theory the extensions need to be updated to register themselves just like any other extension.

This theory is fine for extensions that are really "maintained" by someone, but in the case of "tipafriend" indeed there is the lack of a maintainer. I will try to get in touch with the release team to see if we can make a new release of it including the mentioned TypoScript registration so that it gets compatible with TYPO3 4.6 and later out-of-the-box.

In the meanwhile you will have to add the workaround TypoScript to your own setup. Don't forget that you might also need the TypoScript that previously was provided by "statictemplates" (static SQL records in static_templates which might already have been added in your installation if you are upgrading from older TYPO3).

I will also try to figure out if other affected old-school extensions might need updates in order to clean that up too.

This is the patch which removed these static templates and TypoScript:

https://review.typo3.org/1275 (Issue #23836).

Thanks for your input!

#5 Updated by dermueller no-lastname-given almost 7 years ago

Hi Ernesto, thank you four your quick response to this issue! The problem and its solution now seem clear to me. I thought I had missed a whole new way of inserting those old plugins.

You wrote that there is no maintainer of tipafriend right now, so if you need one, I would like to volunteer for it. I have made 2 entries in the tipafriend-bugtracker on forge this morning. If I was the maintainer, I could solve all of this directly. I also have some ideas how to make the extension a bit better. So if this is an option for you, please let me know.

#6 Updated by Ernesto Baschny almost 7 years ago

  • Status changed from New to Accepted

FYI, I contacted Thorsten Kahler (currently listed as "leader" together with Kasper on http://forge.typo3.org/projects/show/extension-tipafriend. Let's see if I get some feedback from him about the issue. Thanks for your patience!

#7 Updated by Alexander Opitz about 4 years ago

  • Status changed from Accepted to Needs Feedback
  • Is Regression set to No

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

#8 Updated by Riccardo De Contardi over 3 years ago

I guess that this method of registering plugins has been completely removed...

if you are interested, I see that Tip-a-Friend has been updated the last time in 2008 and there is another extension called Tip-a-Friend Plus which is declared compatible with 6.2.x

Do you think this could be closed?

#9 Updated by dermueller no-lastname-given over 3 years ago

Yes, this should be closed. This extension is horribly outdated and I do not use it in my Projects any longer, also because of the huge spam problems which it creates. In my opinion, the extension should be removed from TER.

I have not tested the "plus" version or newer TYPO3 core versions, though.

#10 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Needs Feedback to Closed

I guess all these kind of extensions could be misused and become sources of spam:)

Closed upon request of the reporter.

Also available in: Atom PDF