Bug #38460

Epic #61834: Create future proof Content Element with strong default

Task #61836: Reorganize Content Element properties within backend Extension

Task #61842: Refactor CSS-Styled-Content + Content Elements

Using media-element --> Flashfallback fails

Added by Nic Oemler about 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Content Rendering
Target version:
-
Start date:
2012-06-28
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Using the media-element on 4.7.1 with workaround from #Bug #37938 HTML5-output is fine in all browsers which can handle this. In Firefox flashfallback does not work and gives the User "File not found". If you take a look at the sourcecode you see the right path and if you copy the path to the browser, the right file is loaded. I tested it on 5 different installations (blank, fresh install, introductionpackage, updated from 4.6) and same error on all installations.


Related issues

Related to TYPO3 Core - Bug #41279: Media Element Flash fallback fails Closed 2012-09-23

History

#1 Updated by Andreas Mayer about 7 years ago

I have a similar issue with Typo3/4.7.4.

Steps to reproduce:

1. Create empty Typo3/4.7.4, DOCTYPE html5, minimal template
2. Insert a HTML5 media element
2a. Add mp4/WebM sources
2b. Add fallback flash source

Results:

HTML code is generated correctly. HTML5 video renders fine in Firefox. If you try in Internet Explorer, loading the video fails. The Webserver log says:

(mydomain) 86.33.124.73 - [26/Aug/2012:17:45:09 +0200] "GET /typo3/contrib/flashmedia/video.flv HTTP/1.1" 404 199 "http://(mydomain)/typo3/contrib/flashmedia/flvplayer.swf" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)" 3.03

This file (/typo3/contrib/flashmedia/video.flv) doesn't exist so the server returns 404.

Expected results:

flvplayer.swf should load the fallback FLV file instead of the missing file "video.flv".

If I can provide more helpful information, please let me know.

#2 Updated by Andreas Mayer about 7 years ago

  • Priority changed from Should have to Must have

Suggesting priority "Must have" because this is a major bug on an existing feature (HTML5 video).

#3 Updated by Andreas Mayer almost 7 years ago

Possibly a duplicate of bug #41279.

#4 Updated by Stefan Galinski almost 7 years ago

A small bloated fix for the issue that the player urls don't support the absRefPrefix option. I got the same issue with the video.flv after I fixed that issue first.

tt_content.swfobject.20.video.player = {TSFE:absRefPrefix}{$styles.content.media.flowPlayer}
tt_content.swfobject.20.video.player.insertData = 1

tt_content.swfobject.20.audio.player = {TSFE:absRefPrefix}{$styles.content.media.flowPlayer}
tt_content.swfobject.20.audio.player.insertData = 1

tt_content.qtobject.20.video.player < tt_content.swfobject.20.video.player
tt_content.qtobject.20.audio.player < tt_content.swfobject.20.audio.player

tt_content.media.20.mimeConf.swfobject.video.player < tt_content.swfobject.20.video.player
tt_content.media.20.mimeConf.swfobject.audio.player < tt_content.swfobject.20.audio.player
tt_content.media.20.mimeConf.qtobject.video.player < tt_content.qtobject.20.video.player
tt_content.media.20.mimeConf.qtobject.audio.player < tt_content.qtobject.20.audio.player

tt_content.media.20.mimeConf.flowplayer.video.player = {TSFE:absRefPrefix}{$styles.content.media.flowPlayer}
tt_content.media.20.mimeConf.flowplayer.video.player.insertData = 1
tt_content.media.20.mimeConf.flowplayer.audio.player < tt_content.media.20.mimeConf.flowplayer.video.player

#5 Updated by Stefan Galinski almost 7 years ago

  • Status changed from New to Accepted

#6 Updated by Stefan Galinski almost 7 years ago

I adjusted the solution above to fix the fallback behaviour too. Just set this typoscript in the template where you include the CSC static typoscript. It seems that the wrong player was used and absRefPrefix was not supported yet. Would be great if someone can try it out and a report back if it's not just working in my case. :-)

BTW: The following resource is really helpful to understand the degradion process.

http://flowplayer.blacktrash.org/graceful.html

#7 Updated by Andreas Mayer almost 7 years ago

Thank you, this is working for me. I hope that this fix makes it into the next minor release.

#8 Updated by Christian Hennecke almost 7 years ago

I can confirm that this issue still exists in TYPO3 4.7.5 (which contains a bugfix for the media element) and that Stefan's TypoScript does fix it.

#9 Updated by Thomas Scholze almost 7 years ago

The fix works for me too, TYPO3 v4.7.7.
Thank you.

#10 Updated by Lorenz Ulrich over 6 years ago

Works for me in latest 4.7, too. From comparing the TypoScript posted here by Stefan, I'm not sure if it's really a bug or if it only occurs in certain setups (the page affected in my case is using absRefPrefix).

Does someone know if this is reproducible in a site with default settings (no absRefPrefix)? If so, we should push a patch for css_styled_content to Gerrit.

#11 Updated by Andreas Mayer over 6 years ago

Lorenz Ulrich wrote:

Does someone know if this is reproducible in a site with default settings (no absRefPrefix)? If so, we should push a patch for css_styled_content to Gerrit.

I had this problem, too, and I have never used absRefPrefix.

#12 Updated by Matthias Krappitz over 6 years ago

Same problem also occurs on TYPO3 6.0.4. No problem when switching to flowplayer with the TS given above, except for the fact that I can't find a way to turn autoplay off in flowplayer by default.

#13 Updated by Stefan Galinski over 6 years ago

  • Category set to Content Rendering
  • Complexity set to easy

#14 Updated by Christian Buelter over 6 years ago

Issue still exists in TYPO3 6.1.1

Typoscript code above works for me.

#15 Updated by Tobias Gaertner over 6 years ago

TS does only work partly for me
TYPO3 v.4.7.8

with the TS above it works fie in FF and IE10 (I have only a mp4-Video that should also work in Safari and Chrome)
In chrome the Player works but crashes if I stop the video. In Safari it does not work at all.

Maybe its because of the video-format? But the fallback does'n work at all!

#16 Updated by Alexander Bigga about 6 years ago

The TS patch is working for me on TYPO3 4.7.12. We don't use absRefPrefix.

IE8 is now using the right flowplayer (not flvplayer) and plays the flash video.

Chromium, FF 17 and Opera play the provided mp4 or webm versions as expected.

So, what about taking this patch to the next bugfix release?

#17 Updated by Peter Niederlag almost 6 years ago

  • Is Regression set to No

same problem on 6.1-beta1, replacing the flvplayer.swf by the flowplayer as suggested by Stefan Galinski works.

#18 Updated by Felix Kopp almost 5 years ago

  • Parent task set to #61842

#19 Updated by Ingo Schmitt over 4 years ago

Is this issue still pending in 6.2?

#20 Updated by Georg Ringer almost 4 years ago

  • Status changed from Accepted to Closed

mediace has been extracted from the core and is not needed anymore using CMS7. however it can be now found at github ant the issue has been moved to https://github.com/FriendsOfTYPO3/mediace/issues/15

Also available in: Atom PDF