Bug #39814

Missing label falls back to English solely

Added by Xavier Perseguers over 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
-
Start date:
2012-08-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since #39220, a missing label always falls back to English instead of taking the fall back mechanism introduced in TYPO3 4.6.


Related issues

Follows TYPO3 Core - Bug #39220: Non-localized labels do not fall back properly to default languageClosedXavier Perseguers2012-07-24

Actions
#1

Updated by Xavier Perseguers over 8 years ago

Parent bug was present in Frontend, not in Backend.

#2

Updated by Xavier Perseguers over 8 years ago

Problem located in my case in an Extbase extension because Extbase relies as standard Frontend rendering on config.language_alt to define an alternative language key.

We first have to revert #39220 I'd say because fall back mechanism introduced in 4.6 does not work anymore, it always falls back to English (= source).

By reverting though, we have the bug again in Frontend that a missing translation results in blank output, seems even when using config.language_alt (at least with Extbase).

But then, this config.language_alt is not an option because by reverting the patch, we are forced to set this to "en" in order to tackle with partially translated languages.

BTW, this does not seem to work with Extbase which seems not to properly fall back to the other language.

TYPO3 4.6 introduced a multiple-level fallback which cannot be handled by config.language_alt. I would expect the standard fallback mechanism introduced by TYPO3 4.6 to be automatically taken into account. The question is how? Because then config.alt_language does not make sense anymore.

#3

Updated by Xavier Perseguers over 8 years ago

Tested this with a user-defined language, namely de_AT which should automatically fall back to "de" according to documentation :) Then add a partially translated file and you're done!

User-defined language is described for instance here: http://xavier.perseguers.ch/en/tutorials/typo3/articles/managing-localization-files.html#c954

#4

Updated by Markus Klein over 8 years ago

Please do not test anything here with Extbase. Current implementation of translation in extbase is plain wrong.
If 4.6+ alternative language does not work at all, and fallback to default language doesn't work either.

[1] changes the translation handling in extbase to be the same as in core.

[1] https://review.typo3.org/13039

#5

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/13800

#6

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/13801

#7

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/13802

#8

Updated by Markus Klein over 8 years ago

By the way: pibase getLL also does not handle alternative fallback correctly!!

#9

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/13800

#10

Updated by Xavier Perseguers over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#11

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF