Bug #40782

dontvalidate ignored in ValidatorResolver

Added by Nico de Haen about 8 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2012-09-10
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The ValidatorResolver tries to resolve the Validator for a model class by testing for naming conventions. This mechanism is not skipped, if the dontvalidate annotation is set. Thus I can not use the naming convention if I have a single action, where the validation is not needed.

Example:

newBookingAction (dontvalidate)

previewBookingAction (dontvalidate) since it shows the current progress

createBookingAction (validate)

My validator is called BookingValidator and is executed each time if an argument of type Tx_MyExt_Domain_Model_Booking is found.

It is possible to rename the Validator and add it explicitly as annotation but ignoring the "dontvalidate" annotation is definitely unexpected behaviour (and it took me half an hour to figure out, where the mistake was...)

I think the $validatorConjunctions with parameter names that are annotated as "dontvalidate" should be ignored.


Related issues

Related to TYPO3 Core - Bug #58947: Ignorevalidation set, but validated anyway | also for allready created entities Needs Feedback 2014-05-20

History

#1 Updated by Anja Leichsenring almost 8 years ago

  • Status changed from New to Accepted
  • Assignee set to Anja Leichsenring
  • Target version set to Extbase 6.1

I will have a look into this.

#2 Updated by Alexander Schnitzler over 7 years ago

  • Target version changed from Extbase 6.1 to Extbase 6.2

#3 Updated by Anja Leichsenring over 7 years ago

  • Target version changed from Extbase 6.2 to Extbase 6.3

#4 Updated by Anja Leichsenring about 6 years ago

  • Status changed from Accepted to New

#5 Updated by Alexander Opitz about 6 years ago

  • Project changed from Extbase MVC Framework to TYPO3 Core
  • Category changed from Extbase: Validation to Extbase
  • Target version changed from Extbase 6.3 to 7.0
  • TYPO3 Version set to 6.2
  • Is Regression set to No

#6 Updated by Mathias Schreiber almost 6 years ago

  • Target version changed from 7.0 to 7.1 (Cleanup)

#7 Updated by Benni Mack over 5 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)

#8 Updated by Susanne Moog about 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#9 Updated by Benni Mack about 5 years ago

  • Target version deleted (7.5)

#10 Updated by Anja Leichsenring over 3 years ago

  • Assignee deleted (Anja Leichsenring)

#11 Updated by Susanne Moog 7 months ago

  • Status changed from New to Needs Feedback

Is that still the case in newer TYPO3 versions? If I remember correctly the magical mapping between names and validators has been resolved.

#12 Updated by Susanne Moog 7 months ago

  • Related to Bug #58947: Ignorevalidation set, but validated anyway | also for allready created entities added

#13 Updated by Benni Mack 5 months ago

  • Status changed from Needs Feedback to Closed

Closing this one now due to lack of feedback.

Also available in: Atom PDF