Bug #40819

Epic #90674: Backend UI not reflecting permissions

Edit icons (pencils) still visible in WS even though use has no modify access

Added by Bart Dubelaar about 8 years ago. Updated 6 months ago.

Status:
Accepted
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2012-09-11
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When a user had no access to modify a certain table (as defined in access lists) then the pencils in the record listing are not shown. This doesn't work when working in a workspace. The pencils are still there and clicking them will get you in a blank screen that you cannot exit.
There are even save buttons in the top toolbar that generate a token error when clicking them.

Holds for 4.5 up till 6.0


Related issues

Related to TYPO3 Core - Bug #89307: List Module shows edit action icon even if User has no edit permission Closed 2019-09-30

History

#1 Updated by Bart Dubelaar about 8 years ago

I now see that this doesn't work in the Live workspace either! Pencils only disappear when setting editing permissions in the access module.
Still believe that this is buggy..

#2 Updated by Jigal van Hemert about 8 years ago

  • Status changed from New to Accepted
  • Target version set to 4.5.20

Reproducing:
- edit non-admin user / usergroup
- Access lists > Tables (listing) > mark "Website User"
- Access lists > Tables (modify) > make sure "Website User" is NOT checked

This user can now view the FE users, has access to the edit icon, but sees a blank form.

#3 Updated by Mathias Schreiber almost 6 years ago

  • Target version changed from 4.5.20 to 7.1 (Cleanup)
  • Is Regression set to No

#4 Updated by Benni Mack over 5 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)

#5 Updated by Susanne Moog about 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#6 Updated by Benni Mack about 5 years ago

  • Category changed from Backend User Interface to Workspaces
  • Target version deleted (7.5)

#7 Updated by Riccardo De Contardi over 4 years ago

still an issue on 8.2-dev (latest master)

#8 Updated by Riccardo De Contardi 8 months ago

The issue is still present on 10.4.0-dev; it is not related to workspaces IMHO, as it occurs even on LIVE workspace, just entering the list view and you'll see an edit icon on the records that the editor is not supposed to modify.

#9 Updated by Riccardo De Contardi 8 months ago

  • TYPO3 Version changed from 6.0 to 9

#10 Updated by Riccardo De Contardi 8 months ago

  • Related to Bug #89307: List Module shows edit action icon even if User has no edit permission added

#11 Updated by Riccardo De Contardi 8 months ago

  • Parent task set to #90674

#12 Updated by Riccardo De Contardi 6 months ago

#89307 has been solved, is this solved, too? How can it be tested? (See #90954 that's why I ask)

Also available in: Atom PDF