Project

General

Profile

Actions

Bug #40819

closed

Epic #90674: Backend UI not reflecting permissions

Edit icons (pencils) still visible in WS even though use has no modify access

Added by Bart Dubelaar almost 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2012-09-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When a user had no access to modify a certain table (as defined in access lists) then the pencils in the record listing are not shown. This doesn't work when working in a workspace. The pencils are still there and clicking them will get you in a blank screen that you cannot exit.
There are even save buttons in the top toolbar that generate a token error when clicking them.

Holds for 4.5 up till 6.0


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #89307: List Module shows edit action icon even if User has no edit permissionClosed2019-09-30

Actions
Actions #1

Updated by Bart Dubelaar almost 12 years ago

I now see that this doesn't work in the Live workspace either! Pencils only disappear when setting editing permissions in the access module.
Still believe that this is buggy..

Actions #2

Updated by Jigal van Hemert almost 12 years ago

  • Status changed from New to Accepted
  • Target version set to 4.5.20

Reproducing:
- edit non-admin user / usergroup
- Access lists > Tables (listing) > mark "Website User"
- Access lists > Tables (modify) > make sure "Website User" is NOT checked

This user can now view the FE users, has access to the edit icon, but sees a blank form.

Actions #3

Updated by Mathias Schreiber over 9 years ago

  • Target version changed from 4.5.20 to 7.1 (Cleanup)
  • Is Regression set to No
Actions #4

Updated by Benni Mack about 9 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)
Actions #5

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #6

Updated by Benni Mack over 8 years ago

  • Category changed from Backend User Interface to Workspaces
  • Target version deleted (7.5)
Actions #7

Updated by Riccardo De Contardi about 8 years ago

still an issue on 8.2-dev (latest master)

Actions #8

Updated by Riccardo De Contardi over 4 years ago

The issue is still present on 10.4.0-dev; it is not related to workspaces IMHO, as it occurs even on LIVE workspace, just entering the list view and you'll see an edit icon on the records that the editor is not supposed to modify.

Actions #9

Updated by Riccardo De Contardi over 4 years ago

  • TYPO3 Version changed from 6.0 to 9
Actions #10

Updated by Riccardo De Contardi over 4 years ago

  • Related to Bug #89307: List Module shows edit action icon even if User has no edit permission added
Actions #11

Updated by Riccardo De Contardi over 4 years ago

  • Parent task set to #90674
Actions #12

Updated by Riccardo De Contardi about 4 years ago

#89307 has been solved, is this solved, too? How can it be tested? (See #90954 that's why I ask)

Actions #13

Updated by Oliver Bartsch about 3 years ago

  • Status changed from Accepted to Closed

Just checked this and as Riccardo already mentioned, this was fixed with #89307. #90954 does not seem to be related.

I'll therefore close this issue. If you still experience this bug, please contact me so I can reopen the issue or directly create a new one.

Actions

Also available in: Atom PDF