Bug #41511

Epic #62041: twbs Bootstrap backend, refactor EXT:t3skin and HTML5 output

Epic #62836: FormEngine PHP/HTML Improvements & Bootstrap

TCA eval int,required does not accept 0 (zero)

Added by Markus Klein over 7 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2012-10-02
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Having a TCA setting like

'config' => array(
  ...
  'eval' => 'int,required'
)

does not allow the valid value 0 (zero) in the form. Whenever 0 is entered, the value is removed and the required field marker is shown.

Switching the two keywords (required,int) allows the value 0, even though the 0 is not displayed in the field, but is removed automatically.

This is inconsistent!


Related issues

Related to TYPO3 Core - Bug #70288: Eval int required check allows 0 Closed 2015-10-02

History

#1 Updated by Steffen Gebert over 7 years ago

  • Status changed from New to Accepted
  • Priority changed from Must have to Should have

Sounds reasonable, can you check in the code, why this happens?

#2 Updated by Mathias Schreiber over 5 years ago

  • Target version set to 7.0
  • Is Regression set to No

#3 Updated by Felix Kopp over 5 years ago

  • Parent task set to #62836

#4 Updated by Mathias Schreiber over 5 years ago

  • Target version changed from 7.0 to 7.1 (Cleanup)

#5 Updated by Markus Klein about 5 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)

#6 Updated by Susanne Moog almost 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#7 Updated by Benni Mack over 4 years ago

  • Target version changed from 7.5 to 7 LTS

#8 Updated by Daniel Goerz over 4 years ago

  • Status changed from Accepted to Needs Feedback

I cannot reproduce this error on 7.6-dev. I can enter 0 into fields with 'required,int' as well as 'int,required' and save successfully. So the question raises if someone else could reproduce this behavior. Then please update the ticket.

#9 Updated by Markus Klein over 4 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (7 LTS)

Closing this for the time being. The rewritten FormEngine for sure does not care about the order of evals anymore.

Also available in: Atom PDF