Bug #44551

Image caption appears under wrong image

Added by Marcel Burkhalter over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-01-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Steps to reproduce:
- Create a CE with two FAL IRRE images
- Add a description for the second file
--> in the FE the description is displayed as caption for the first image


Related issues

Has duplicate TYPO3 Core - Bug #44046: Description (Caption) allocation in TYPO3 6.0.0ClosedBenni Mack2012-12-17

Actions
Has duplicate TYPO3 Core - Bug #45346: css_styled_content and imageTextSplit Closed2013-02-10

Actions
#1

Updated by Jigal van Hemert over 8 years ago

  • Category set to File Abstraction Layer (FAL)
#2

Updated by Andreas Wolf over 8 years ago

I think this is more related to the TypoScript content rendering, but I have not investigated this. I'll try to reproduce it.

#3

Updated by Ben Robinson over 8 years ago

Similar issue: if the first image has a multiline caption (with line-breaks) the second line is used for the FE-caption of the second image.
I also think that this is related to content rendering (css styled content). A linebreak should not be used for splitting the caption anymore. By the way, RTE-Support for captions could be useful, f.e. to link to the photographer of an image.

#4

Updated by Alexander Opitz over 8 years ago

Examples can be found in #44046

#5

Updated by Alexander Opitz over 8 years ago

On actuall git master caption is fully missing.

I mean on the page http://your_domain/examples/image-groups/ if you installed the introduction package.

The problem is inside css_styled_content, which uses the old field imagecaption instead of the new File API.

#6

Updated by Andreas Wolf over 8 years ago

  • Status changed from New to Accepted
#7

Updated by Henrik Ziegenhain over 7 years ago

I all.

I don´t think #45346 is a duplicate of this issue. Please see my comment there.

But maybe this issue here can be closed due to a duplicate of #48354 - I can´t reproduce the steps from above in version 6.1.7

#8

Updated by Martin Siedl over 7 years ago

i can confirm henrik - this is not resolved with #45346 and the issue still exists in 6.1.7.
if you make newlines in the the multiline caption fields the captions get distributet incorret with the images.
can somebody please give feedback on this issue and reopen the ticket.

#9

Updated by Christian Reiter over 7 years ago

I can confirm this in 6.1.7

Let's say 8 FAL references...

... you can put 8 lines in the caption field of the first reference, separated by newlines, and this will deliver all captions for the images.

Anything entered in the other 7 FAL references is ignored.

... Or you can put 1 line in the caption field of the first reference, and punch in 7 newlines.

Anything entered in the other 7 FAL references is ignored.

As you start deleting the newlines from the first reference then the captions for other elements suddenly "reappear" in the frontend.

It is definitely a css_styled_content problem, this seems to be "backward-compatible" so that you can either manage all references from the first field or put one reference in each field (but must never use a newline anywhere):

This is confusing because there is no use for the oldschool method anymore and a newline should be just passed through and not treated anymore as a separator for data.

#10

Updated by Sander Leeuwesteijn over 7 years ago

Confirmed in 6.1.7. Multiple images with different captions, but all captions show at all images.

#11

Updated by Henrik Ziegenhain over 7 years ago

Tested it recently with TYPO3 6.2.0 - It seems to be resolved with the new LTS Version

Can someone please check this?

#12

Updated by Sander Leeuwesteijn over 7 years ago

It seems the whole TypoScript caption rendering in css_styled_content has changed significantly in 6.2.0. (compared to 6.1.7)

#13

Updated by Frans Saris over 7 years ago

  • Status changed from Accepted to Needs Feedback
  • Is Regression set to No

Can someone confirm that this is fixed in 6.2?

#14

Updated by Christian Reiter over 7 years ago

Tried on current master, it is fixed.

The line break problem described in #3 is also fixed. In early versions the line break was still used to assign captions to images.

Test:
  • Create 3 FAL image references in a CE
  • Put description only into third image => shown correctly
  • Move description to second image but start the description with a line break, or make a two.line description with line break in between => shown correctly.
#15

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF