Bug #44046

Description (Caption) allocation in TYPO3 6.0.0

Added by Daniel Kurzweg about 9 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Content Rendering
Target version:
-
Start date:
2012-12-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In a regular image content element i'm trying to add a text to the "Description (Caption)" field. It works fine however if the first image has no text in the "Description (Caption)" filed it'll get allocated with the first text of any image with a Description (Caption) text.

so this in the TYPO3 backend (see screenshot) :

image > Description (Caption)
jpg1 >
jpg2 >
jpg3 > Quod erat demonstrandum
jpg4 > Lorem Ipsum

gets outputted as this (see screenshot):

image > Description (Caption)
jpg1 > Quod erat demonstrandum
jpg2 > Lorem Ipsum
jpg3 >
jpg4 >

However the allocation fails for the Description (Caption) all the other (Title, Alternative Text and Link) are allocated correctly.

Also if the first image has a Description (Caption) all the following Description (Caption) allocation is correct even if one is missing in-between.


Files

Bildschirmfoto_2012-12-17_um_11.18.06.png (60.6 KB) Bildschirmfoto_2012-12-17_um_11.18.06.png HTML Output Daniel Kurzweg, 2012-12-17 11:37
Bildschirmfoto_2012-12-17_um_11.18.21.png (37.8 KB) Bildschirmfoto_2012-12-17_um_11.18.21.png TYPO3 6.0.0 input Daniel Kurzweg, 2012-12-17 11:37
Image1.png (15.5 KB) Image1.png Claus Harup, 2013-01-10 10:22
Image2.png (5.08 KB) Image2.png Claus Harup, 2013-01-10 10:22

Related issues

Is duplicate of TYPO3 Core - Bug #44551: Image caption appears under wrong imageClosed2013-01-15

Actions
#1

Updated by Claus Harup about 9 years ago

Im having the exact same problem :-)

See attached

#2

Updated by Thorsten Kahler almost 9 years ago

This is not a FAL issue, it's caused by content rendering.

#3

Updated by Thorsten Kahler almost 9 years ago

  • Project changed from 1401 to TYPO3 Core
#4

Updated by Thorsten Kahler almost 9 years ago

  • Category set to Content Rendering
  • Status changed from New to Accepted
  • TYPO3 Version set to 6.0
#5

Updated by Benni Mack almost 9 years ago

  • Assignee set to Benni Mack
#6

Updated by Alexander Opitz over 7 years ago

  • Status changed from Accepted to Closed

Also available in: Atom PDF