Bug #45595

Unable to clear cache in IE<9

Added by Timo Bartholomes over 8 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-02-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since the update to version 4.5.23 I'm unable to clear the in Internet Explorer < 9.

I deleted the whole typo3temp/compressor folder but onclick the browser reports an error in file typo3temp/compressor/prototype-95ab4563f841d139fe8705d1d5a55e8a.js with:

Meldung: 'nodeType' ist Null oder kein Objekt
Zeile: 3861
Zeichen: 7
Code: 0
URI: http://&lt;domain&gt;/typo3temp/compressor/prototype-95ab4563f841d139fe8705d1d5a55e8a.js

Maybe related to #36364

Regards
Timo


Files

45595.diff (497 Bytes) 45595.diff Andreas Kiessling, 2013-02-23 13:18

Related issues

Related to TYPO3 Core - Bug #36364: Clear all caches with IE9 results in blank pageClosedJigal van Hemert2012-04-20

Actions
Related to TYPO3 Core - Bug #47079: Cleare cache all doesn't work in Internet Explorer 10Closed2013-04-09

Actions
#1

Updated by Philipp Gampe over 8 years ago

Can you disable the compression (e.g. with BE|debug in Install Tool)? That should give you a better reable version and a hint where this bug really is.
Mind that BE|debug will break the CSS in IE.

#2

Updated by Timo Bartholomes over 8 years ago

[BE][debug] results in exactly the same error, only filename and path changes from

typo3conf/compressor/prototype-95ab4563f841d139fe8705d1d5a55e8a.js
to
typo3/contrib/prototype/prototype.js
#3

Updated by Timo Bartholomes over 8 years ago

I just copied typo3/js/clearcachemenu.js from 4.5.22 to the 4.5.23 sources and it worked again for IE8, but results in blank page in IE9 (as expected)

#4

Updated by Georg Ringer over 8 years ago

  • Status changed from New to Accepted
#5

Updated by Georg Ringer over 8 years ago

  • Status changed from Accepted to Needs Feedback

please remove typo3temp content and recheck with really removed IE caches. I can't reproduce it here

#6

Updated by Timo Bartholomes over 8 years ago

i just did a clean install (vm with win7, xampp and typo3_src+dummy-4.5.23). IE8 version is 8.0.7600.16385 and even with this setup cached files remain in typo3conf after choosing "clear all caches".

The environment I tested in first was with strict antivirus (which I can't turn off) and stuff so I decided to do that clean install (other machine without antivirus and stuff, clean windows).

#7

Updated by Andreas Kiessling over 8 years ago

I can confirm the error and wonder, why my patch was even backported to 4.5 and 4.6
These versions ship with

<meta http-equiv="X-UA-Compatible" content="IE=8" />

so there was nothing to fix for IE > 8, since prototype works "fine" in this mode.
All reports were only mentioning 4.7 and 6.0

IE8 fails to pass the event information to the click handler and thus the clearCache function can not determine the element that was clicked.

The attached patch seems to fix the issue again and fetches the event information from the window object if it is not passed to the click handler.

#8

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18453

#9

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/18795

#10

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/18796

#11

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at https://review.typo3.org/18797

#12

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/18798

#13

Updated by Andreas Kiessling over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#14

Updated by Stephan Großberndt over 8 years ago

The patched line

event = event || window.event;

is not present in the current 4.5.25 and 4.7.10 release. Will it be included in 4.5.26 / 4.7.11?

Only the changelog of TYPO3 6.1 includes "[BUGFIX] Clearing cache from toolbar fails in IE8".

In (at least) Internet Explorer 9 and 10 clearing the cache currently does not work (X-UA-Compatible" content="IE=8" is set). In 4.5 nodeType-Javascript-Error, in 4.7 white page.

#15

Updated by Nicole Cordes over 8 years ago

As the change is already in the current version masters you could either checkout them or wait until the next release announcement.

#16

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF