Bug #47004

CSS Styled Content | renderMethod = table

Added by Claus Harup almost 6 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
-
Start date:
2013-04-06
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I could not find the right project to add this bug :-(

After upgrading to TYPO3 CMS 6.0 (using FAL) the configuration "tt_content.image.20.renderMethod = table" does not work any more;

The text is rendered but no images are rendered.

I use this configuration to change the rendering in my newsletter setup where tables is required.

It worked perfectly in TYPO3 CMS up to 4.7


Related issues

Duplicates TYPO3 Core - Bug #46864: renderMethod=table (IMGTEXT rendering) not compatible with FAL yet Closed 2013-04-02

Associated revisions

Revision bce5ae7b (diff)
Added by Torben Hansen about 4 years ago

[BUGFIX] Fix image rendering for renderMethod = table

Since the introduction of FAL to TYPO3, the rendering of images
using CSS styled content with renderMethod = table is broken.

Using a single image results in the image being rendered twice
and if you have multiple images in one content object, only the
last image is rendered multiple times (depending on the amount
of images in the content object).

This patch resolves both issues and loads the current image file
reference to the contentObjectRenderer while looping through the
images of the content object.

Resolves: #46864
Related: #47004
Releases: master, 6.2
Change-Id: If120267111e30de6438cecc5e14cea34bc6fa235
Reviewed-on: http://review.typo3.org/35407
Reviewed-by: Anja Leichsenring <>
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision cdf957db (diff)
Added by Torben Hansen about 4 years ago

[BUGFIX] Fix image rendering for renderMethod = table

Since the introduction of FAL to TYPO3, the rendering of images
using CSS styled content with renderMethod = table is broken.

Using a single image results in the image being rendered twice
and if you have multiple images in one content object, only the
last image is rendered multiple times (depending on the amount
of images in the content object).

This patch resolves both issues and loads the current image file
reference to the contentObjectRenderer while looping through the
images of the content object.

Resolves: #46864
Related: #47004
Releases: master, 6.2
Change-Id: If120267111e30de6438cecc5e14cea34bc6fa235
Reviewed-on: http://review.typo3.org/35704
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Patrick Broens almost 6 years ago

  • Status changed from New to Needs Feedback

css_styled_content rendermethod table is from TYPO3 CMS versions below 4.7. Since 4.7 a lot has changed and this render method does not exist anymore in the current TypoScript from css_styled_content. The render method is still supported, but you need to use the TypoScript from an older css_styled_content/typo3 version.

#2 Updated by Torben Hansen almost 6 years ago

Under some circumstances you must have the possibility to render images in tables (e.g. when creating newsletters, which must be compatible with a lot of e-mail clients). The only way to get tables for the images in TYPO3 v6+ is to use "CSS Styled Content TYPO3 v4.7" for the newsletter template.

Actually it seems that this rendering method is only half supported in TYPO3 v6+ css_styled_content, since actually a table structure is rendered to the output, just the images are missing.

#3 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to New

#4 Updated by Torben Hansen over 4 years ago

This problem still exists in TYPO3 6.2 and the approach using CSS styled content v4.7 does only work, if you enable [FE][activateContentAdapter] in TYPO3 install tool. The TYPO3 Install tool shows a warning, that using [FE][activateContentAdapter] is slow.

I'll try to create a patch for this bug, which also should resolve #46864

#5 Updated by Torben Hansen over 4 years ago

Patch has been submitted for review: https://review.typo3.org/#/c/35407/

#6 Updated by Benni Mack about 4 years ago

  • Status changed from New to Closed
  • Is Regression set to No

duplicate of #46864

Also available in: Atom PDF