Bug #48464

Images in workspaces don't work

Added by nurbs999 no-lastname-given over 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2013-05-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In the backend I can't see the images of 'Text with image' elements if I use workspaces (another than live). They only show up in all workspaces once the element is published.

Steps to reproduce:
Fresh TYPO3 6.0.5 installation.
1. Login into backend
2. Install system extension 'workspaces'
3. create a filemount
4. create a workspace
5. reload backend
6. switch into new workspace
7. select page->any_page_you_want
8. add content element to page
9. select 'text with image'
10. add an image from filemount
11. save and close
12. voila, no image


Files

Bildschirmfoto_2013-07-17_um_13.41.42.png (204 KB) Bildschirmfoto_2013-07-17_um_13.41.42.png Backend view in the WS Markus Günther, 2013-07-17 13:43
Screenshot_17.07.13_13_42.png (446 KB) Screenshot_17.07.13_13_42.png FE Preview with a missing image under the headline Markus Günther, 2013-07-17 13:43
cattura1.png (147 KB) cattura1.png Riccardo De Contardi, 2015-09-12 22:28
cattura2.png (121 KB) cattura2.png Riccardo De Contardi, 2015-09-12 22:28
cattura3.png (193 KB) cattura3.png Riccardo De Contardi, 2015-09-12 22:28
cattura4.png (97.5 KB) cattura4.png Riccardo De Contardi, 2015-09-12 22:28
cattura5.png (90.4 KB) cattura5.png Riccardo De Contardi, 2015-09-12 22:28
cattura6.png (181 KB) cattura6.png Riccardo De Contardi, 2015-09-12 22:28

Related issues

Related to TYPO3 Core - Bug #46742: CE text with image in workflow: FAL images are in workflow even when not editedClosed2013-03-28

Actions
Related to TYPO3 Core - Task #43916: File Repository does not work with WorkspacesClosedBenni Mack2012-12-12

Actions
#2

Updated by nurbs999 no-lastname-given over 8 years ago

  • Project changed from TYPO3 Core to 624
  • Category deleted (Backend User Interface)
  • Assignee set to Oliver Hader
#3

Updated by Frank Gerards over 8 years ago

  • Target version changed from 6.0.5 to 2338

I dont know if FAL supports workspaces and versioning to 100% right now.

Ofc versioning and workspaces is a killer feature besides multi-domain for bigger enterprise projects and
for projects requiring an author workflow, plz fix it soon or communicate a roadmap for it

#4

Updated by Ernesto Baschny over 8 years ago

  • Target version deleted (2338)
#5

Updated by Oliver Hader about 8 years ago

  • Assignee deleted (Oliver Hader)
#6

Updated by Oliver Hader about 8 years ago

  • Status changed from New to Needs Feedback

Does the image not show up in the backend (Web>Page column view) or in the frontend-preview?

#7

Updated by Markus Günther about 8 years ago

I test it with a TYPO3 CMS 6.1 and the problem is still there.

Steps to reproduce:
- log into the backend
- switch to workspace
- create a content element with an image
- save the ce and then in the backend the preview image is missing

- in the frontend preview the image is also missing and the last build query fails:

INSERT INTO cache_imagesizes (md5hash,md5filename,tstamp,filename,imagewidth,imageheight) VALUES ('e7a3b8f2f266958cba1567253f25e6ee','a714d19ea77b0c14af6712eeb57dd6cf','1374054200','typo3temp/pics/d92587b97b.png','287','166')

#8

Updated by Markus Günther about 8 years ago

The Error in the frontend is a result of a missing check in the FrontendContentAdapterService.php. In the method modifyDBRow the file repository gets only the record uid of the original or of the language overlay. The method don't have a look for the workspace record uid.

So all files of any workspaces records can not be found.

$files = $fileRepository->findByRelation($table, $migrateFieldName, isset($row['_LOCALIZED_UID']) ? intval($row['_LOCALIZED_UID']) : intval($row['uid']));

If you also check for isset($row['_ORIG_uid'], then you will get the images also from the workspace.

I am not the expert in WS so i am not sure if it is enough to do something like this:

                    if (isset($row['_ORIG_uid'])) {
                        $relatedRecordUid = intval($row['_ORIG_uid']);
                    } elseif (isset($row['_LOCALIZED_UID'])) {
                        $relatedRecordUid = intval($row['_LOCALIZED_UID']);
                    } else {
                        $relatedRecordUid = $row['uid'];
                    }

                    $files = $fileRepository->findByRelation($table, $migrateFieldName, $relatedRecordUid);

#9

Updated by Lars Malach about 8 years ago

Whats the current state of this issue? Is somebody working on a solution?

I would love to help, but Markus Günther told me, that there are some conceptional meetings currently..

#10

Updated by Marcos Fadul almost 8 years ago

Check the patch for bug 43916. That one worked for me on Typo3 6.1.5.

#11

Updated by Michael Stucki almost 8 years ago

  • Category set to Workspaces
#12

Updated by Michael Stucki almost 8 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
#13

Updated by Alexander Opitz over 7 years ago

  • Category changed from Workspaces to File Abstraction Layer (FAL)
  • Is Regression set to No

Hi,

can you try the patch from #43916 please? And report back if this helps you.

#14

Updated by Konrad Schiertz over 7 years ago

TYPO3 Version 6.1.7
With the patch from 43916 and the changes from Markus Günther images are shown in the frontend preview workspace.
In the Backend not. The Backend view is still like screenshot: Bildschirmfoto_2013-07-17_um_13.41.42.png

#15

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New
#16

Updated by Christiaan Wiesenekker about 7 years ago

Does anybody has a fix for this? Or should we use the patch from 43916?

#17

Updated by Ingo Schmitt over 6 years ago

  • Category changed from File Abstraction Layer (FAL) to Workspaces
#18

Updated by Riccardo De Contardi about 6 years ago

I close this because I cannot reproduce it in both 6.2.15 and 7.5-dev (latest master)

I built a custom workspace and entered the backend with an editor user;
On 6.2.15:
1) I added a text with image CE (see cattura1.png) in the custom workspace
2) save it (cattura2.png); as you can see, the image preview is present
3) in the frontend preview (cattura3.png) the image is visible.

On 7.5-dev (latest master):
4) I added a text with image CE (see cattura4.png) in the custom workspace
5) save it (cattura5.png); as you can see, the image preview is present
6) in the frontend preview (cattura6.png) the image is visible.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF