Project

General

Profile

Actions

Bug #48939

closed

Moving a content down moves it in another column

Added by Fabrice Morin about 11 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2013-06-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

It seems there is a problem with sorting behavior on content element in page view.

It can be reproduced with the following steps :
  • Create a new page
  • Add a new content in the normal column (text content with header set to "test1")
  • Add a new content in the right column (text content with header set to "test2")
  • Move test1 content up; this shouldn't be possible and it has no effect except displaying the down arrow on this content
  • Move test1 content down; here again, it should not be possible. It moves this content from the normal column to the right column.

I guess this have something to do with the getResult function in class.tx_cms_layout.php (line 2061). The prev and next ids are set without taking in account the column position of the content element.

I use typo3 v4.7.12.


Files

class.tx_cms_layout.php.diff (2.49 KB) class.tx_cms_layout.php.diff Siva Prasad, 2013-12-04 08:07

Related issues 4 (0 open4 closed)

Related to TYPO3 Core - Bug #49055: colPos gets messed up when moving content element to top position in backend gridClosed2013-06-12

Actions
Related to TYPO3 Core - Bug #44470: Content elements in wrong column in page moduleClosedOliver Hader2013-01-13

Actions
Related to TYPO3 Core - Bug #60199: Page module: tt_content records are not editableClosedJigal van Hemert2014-07-09

Actions
Has duplicate TYPO3 Core - Bug #49115: Error in core TYPO3 4.7 concerning reorder of elements in page modeClosed2013-06-14

Actions
Actions #1

Updated by Timo Bartholomes about 11 years ago

I have the same behavior in 4.5.27, but thought it might be related to the backend layout.

Actions #2

Updated by Sander Leeuwesteijn almost 11 years ago

Having the same in 4.5.27!

Actions #3

Updated by Thorsten Kahler over 10 years ago

  • Category set to Backend User Interface
  • Status changed from New to Accepted
  • Is Regression set to Yes

This bug is caused by the faulty fix for #44470.

Actions #4

Updated by Daniel Wagner over 10 years ago

This also happens in TYPO3 v4.5.30, v4.5.29 and v4.5.27 (v4.5.28 not tested) - all without workspaces, but using backendlayout.

Some content elements in the first row in different columns have a move up button and some not.
After clicking the up or down button, the content element mostly will appear in a wrong colPos.

Actions #5

Updated by Nicole Cordes over 10 years ago

  • Assignee set to Nicole Cordes
  • Target version set to next-patchlevel
Actions #6

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/25001

Actions #7

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/25001

Actions #8

Updated by Gerrit Code Review over 10 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/25001

Actions #9

Updated by Siva Prasad over 10 years ago

Please check the attached diff file. For me the issue is fixed with these changes . If you guys have some better idea than this one please suggest

Actions #10

Updated by Sander Leeuwesteijn over 10 years ago

It appears this issue also happens in 4.5.32!

Actions #11

Updated by Sander Leeuwesteijn over 10 years ago

Can anyone tell me if this issue will be fixed in 4.5.33?

Actions #12

Updated by Nicole Cordes over 10 years ago

As you can see, this patch is blocked by now. This means it cannot be merged until there is a decision which way to go (see attached review comments).

Actions #13

Updated by Daniel Wagner about 10 years ago

What is the actual state? Do the different opinions converge to a decision? The last entry is from Feb 26.

Actions #14

Updated by Gerrit Code Review almost 10 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/25001

Actions #15

Updated by Gerrit Code Review almost 10 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31492

Actions #16

Updated by Gerrit Code Review almost 10 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31493

Actions #17

Updated by Gerrit Code Review almost 10 years ago

Patch set 1 for branch TYPO3_4-5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31494

Actions #18

Updated by Gerrit Code Review almost 10 years ago

Patch set 2 for branch TYPO3_4-5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31494

Actions #19

Updated by Gerrit Code Review almost 10 years ago

Patch set 1 for branch TYPO3_4-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31495

Actions #20

Updated by Nicole Cordes almost 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #21

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/31497

Actions #22

Updated by Nicole Cordes almost 10 years ago

  • Status changed from Under Review to Resolved
Actions #23

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF