Project

General

Profile

Actions

Bug #50310

closed

DataHandler fails to correctly re-sort (content) elements after moving one to top

Added by Bernhard Schmitt almost 11 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2013-07-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

Tested with v6.1.1, seems to affect 4.7.x too.

This occurs using drag&drop as well as calling the DataHandler itself.

While moving an element to top, its sorting will be set to 0 (the return value of getSortNumber called in line 3512), but the other elements' sorting is not updated. So if you move all elements to the top one after another, they all end up having sorting 0 and will be sorted by their uid instead.

Moving any one of those elements >down< will release the lock by reassigning valid sorting values to all affected content elements.

Best,
Bernhard


Related issues 1 (1 open0 closed)

Related to TYPO3 Core - Bug #68040: Inline localize and/or synchronize does not respect sortingUnder Review2018-03-142018-03-14

Actions
Actions #1

Updated by Philipp Gampe almost 11 years ago

  • Status changed from New to Accepted
  • Target version set to next-patchlevel
  • Complexity set to easy

Can you create a patch based on the code for moving an element down? http://wiki.typo3.org/Git

Actions #2

Updated by Mathias Schreiber over 9 years ago

  • Target version changed from next-patchlevel to 7.4 (Backend)
  • Complexity changed from easy to medium
  • Is Regression set to No
Actions #3

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #4

Updated by Benni Mack over 8 years ago

  • Target version deleted (7.5)
Actions #5

Updated by Andreas Wolf over 6 years ago

Is this probably a duplicate of/related to #68040?

Actions #6

Updated by Benni Mack over 3 years ago

  • Related to Bug #68040: Inline localize and/or synchronize does not respect sorting added
Actions #7

Updated by Benni Mack over 3 years ago

  • Status changed from Accepted to Needs Feedback

We've reworked the sorting in TYPO3 v10, can you re-check please with a more recent version if your issue still occurs? From reading the EXT:core code, other items are now resorted.

Actions #8

Updated by Christian Kuhn over 2 years ago

  • Status changed from Needs Feedback to Closed

Closing due to lack of feedback - it has probably been fixed meanwhile. If the issue persists, please re-open or create a new issue.

Actions

Also available in: Atom PDF