Bug #50363

Fatal error: Call to undefined method TYPO3\CMS\Core\Resource\ProcessedFile::getUpdatedProperties()

Added by Tobias Klepp over 6 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-07-24
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

After installation of TYPO3 6.1.2 I get the following error, if I select my folders in fileadmin to display the images. But I don't get the error for every folder. I updated the TYPO3 from version 6.1.1 to 6.1.2 and I think only folders with metadata in files like images have the problem. Directories with only html files for example are fine.

*Fatal error:* Call to undefined method TYPO3\CMS\Core\Resource\ProcessedFile::getUpdatedProperties() in C:\Daten\arbeit\www\typo3_6\typo3\sysext\core\Classes\Resource\FileRepository.php on line 257

*Call Stack:* 
0.0000 348032 1. {main}() C:\Daten\arbeit\www\typo3_6\typo3\mod.php:0
0.3620 20975368 2. require('C:\Daten\arbeit\www\typo3_6\typo3\sysext\filelist\mod1\index.php') C:\Daten\arbeit\www\typo3_6\typo3\mod.php:41
0.3680 21377016 3. TYPO3\CMS\Filelist\Controller\FileListController->main() C:\Daten\arbeit\www\typo3_6\typo3\sysext\filelist\mod1\index.php:46
0.3960 22281080 4. TYPO3\CMS\Filelist\FileList->generateList() C:\Daten\arbeit\www\typo3_6\typo3\sysext\filelist\Classes\Controller\FileListController.php:290
0.3960 22281152 5. TYPO3\CMS\Filelist\FileList->getTable() C:\Daten\arbeit\www\typo3_6\typo3\sysext\filelist\Classes\FileList.php:199
0.4810 22994112 6. TYPO3\CMS\Filelist\FileList->formatFileList() C:\Daten\arbeit\www\typo3_6\typo3\sysext\filelist\Classes\FileList.php:353
0.6821 24744872 7. TYPO3\CMS\Core\Resource\File->process() C:\Daten\arbeit\www\typo3_6\typo3\sysext\filelist\Classes\FileList.php:622
0.6821 24744872 8. TYPO3\CMS\Core\Resource\ResourceStorage->processFile() C:\Daten\arbeit\www\typo3_6\typo3\sysext\core\Classes\Resource\File.php:293
0.6821 24744872 9. TYPO3\CMS\Core\Resource\Service\FileProcessingService->processFile() C:\Daten\arbeit\www\typo3_6\typo3\sysext\core\Classes\Resource\ResourceStorage.php:773
0.6841 24755096 10. TYPO3\CMS\Core\Resource\ProcessedFile->isProcessed() C:\Daten\arbeit\www\typo3_6\typo3\sysext\core\Classes\Resource\Service\FileProcessingService.php:102
0.6851 24755096 11. TYPO3\CMS\Core\Resource\ProcessedFile->needsReprocessing() C:\Daten\arbeit\www\typo3_6\typo3\sysext\core\Classes\Resource\ProcessedFile.php:274
0.6851 24756016 12. TYPO3\CMS\Core\Resource\ProcessedFile->delete() C:\Daten\arbeit\www\typo3_6\typo3\sysext\core\Classes\Resource\ProcessedFile.php:471
0.6851 24756016 13. TYPO3\CMS\Core\Resource\AbstractFile->delete() C:\Daten\arbeit\www\typo3_6\typo3\sysext\core\Classes\Resource\ProcessedFile.php:413
0.6851 24756016 14. TYPO3\CMS\Core\Resource\ResourceStorage->deleteFile() C:\Daten\arbeit\www\typo3_6\typo3\sysext\core\Classes\Resource\AbstractFile.php:440
0.6861 24756072 15. TYPO3\CMS\Core\Resource\FileRepository->update() C:\Daten\arbeit\www\typo3_6\typo3\sysext\core\Classes\Resource\ResourceStorage.php:993 

Related issues

Related to TYPO3 Core - Bug #48336: sys_file record doesn't get flagged as delete after deleting a file Rejected 2013-05-17
Related to TYPO3 Core - Bug #50508: Re-uploading file in backend fails Closed 2013-07-29
Duplicated by TYPO3 Core - Bug #50377: Since update from 6.0.6 to 6.0.7 extension manager is a blanc page Closed 2013-07-24

History

#1 Updated by Markus Klein over 6 years ago

  • Status changed from New to Accepted

Also 6.0 affected.

#2 Updated by Ernesto Baschny over 6 years ago

  • Category set to 1394
  • TYPO3 Version changed from 6.1 to 6.0

#3 Updated by Frans Saris over 6 years ago

I think it is related to #48336 but I don't understant wy the delete is called when you try to view a folder?

Gr. Frans

#4 Updated by Helmut Hummel over 6 years ago

Frans Saris wrote:

I think it is related to #48336 but I don't understant wy the delete is called when you try to view a folder?

It is related to #48336 and a processed file needs to be (re-) created thus delete is called.

#5 Updated by Frans Saris over 6 years ago

Please do not revert but fix :)

I will have a look at it after lunch

#6 Updated by Ernesto Baschny over 6 years ago

Cool, Frans, thanks for your help! You've got something already?

#7 Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22562

#8 Updated by Frans Saris over 6 years ago

Hi Ernesto,

yes I have got something. Please have a look at it and let me know if this can be a solution or if we should take an other approach.

gr. Frans

#9 Updated by Gernot Ploiner over 6 years ago

I have tested the Patch and it works. Thank you.

#10 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22562

#11 Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22562

#12 Updated by Frans Saris over 6 years ago

Gernot,

Can you please test the latest patch?

Gr. Frans

#13 Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22562

#14 Updated by Julian Wundrak over 6 years ago

Gerrit Code Review wrote:

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22562

This path works very well for me. Thanks!

#15 Updated by Maximilian Anton Grimm over 6 years ago

Julian Wundrak wrote:

Gerrit Code Review wrote:

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/22562

This path works very well for me. Thanks!

Just tested, works great, thx.

#16 Updated by Oliver Hader over 6 years ago

  • Status changed from Under Review to Rejected
  • Target version deleted (next-patchlevel)

The initial change that introduced the regression has been reverted for all branches. The reason for this is, that the concept of using the deleted flag was not supported at all in the file abstraction layer. The topic will be discussed an continued during the FAL code sprint in the first week of August 2013 in Mainz/DE.

#17 Updated by Ernesto Baschny about 6 years ago

  • Is Regression set to Yes

#18 Updated by Ernesto Baschny about 6 years ago

  • Category changed from 1394 to File Abstraction Layer (FAL)

Also available in: Atom PDF