Bug #51546

FILE:EXT:extbase/ext_typoscript_setup.txt not included by default

Added by Loon Buster over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-08-30
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

#1247602160: Table '[X].tx_extbase_domain_model_backenduser' doesn't exist: SELECT tx_extbase_domain_model_backenduser.* FROM tx_extbase_domain_model_backenduser WHERE tx_extbase_domain_model_backenduser.uid = '1' LIMIT 1 (More information)

TYPO3\CMS\Extbase\Persistence\Generic\Storage\Exception\SqlErrorException thrown in file
X]/typo3/sysext/extbase/Classes/Persistence/Generic/Storage/Typo3DbBackend.php in line 1253.

.loon


Related issues

Related to TYPO3 Core - Bug #43365: Backend user Page error after Update to 6.0 Closed 2012-11-27
Related to TYPO3 Core - Bug #52453: Backend / Uncaught exception 'RuntimeException' with message 'No settings detected. This usually happens if there is no frontend TypoScript template with root flag set. Please create one.' Closed 2013-10-02
Related to TYPO3 Core - Bug #51234: Exception with EXT:sys_note is installed Closed 2013-03-13

History

#1 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback

Please describe what do you do to get this exception.

#2 Updated by Loon Buster over 6 years ago

sometimes; mostly after login or a while. in "site" or "list" area.
after "jumping around" and delete the cache it works..

..need t3 a table with a name "tx_extbase_domain_model_backenduser"? yes/no?

.loon

#3 Updated by Chris topher over 6 years ago

..need t3 a table with a name "tx_extbase_domain_model_backenduser"? yes/no?

Isn't the answer obvious? When it is missing, you get an SQL error and an exception, so: Yes, this table is needed! Did you not update your database?

The same error in sys_note has been reported in #46250 (which obviously has been fixed).

#4 Updated by Ernesto Baschny over 6 years ago

According to #51234 this has not be definitively been fixed yet.

Does the problem happen if you uninstall the extension sys_note? If the problem disappears, than this issue is the one reported in #51234 (and we should close this one). If the problem continues, it's another (probably related) problem.

#5 Updated by Loon Buster over 6 years ago

@Chris topher

no, isn't. ..because i don't delete the table! ;)

..as a user i expect that the programm not deleting datas which they need.. or?
maybe i expect too much from t3.. or maybe if a higher standard at my developments - whatever.. back to the topic:

in the upgrade wizard are currently:

- Migrate all file relations from tt_content.image and pages.media
and
- Migrate all RTE magic images from uploads/RTEmagicC_* to fileadmin/_migrated_/RTE/

but this dosen't working! :D

..so i've no idea which bug i must fix first and what is a bug and what not. ..how published this version of t3?

i will check #46250. but seriously i must work on a website not on 20 different bugs :D ..so for my next clients i will use a alternative to t3.

.loon

#6 Updated by Loon Buster over 6 years ago

@Ernesto Baschny

i will check

#7 Updated by Wolfgang Klinger over 6 years ago

@ Chris topher: no, this table does not exist and you won’t find a table definition for that in the whole TYPO3 core … so … makes no sense to tell people they should create this table …

I have the same issue:

sql_query
caller    TYPO3\CMS\Core\Database\DatabaseConnection::sql_query
ERROR    Table 'mydatabase.tx_extbase_domain_model_backenduser' doesn't exist
lastBuiltQuery    SELECT tx_extbase_domain_model_backenduser.* FROM tx_extbase_domain_model_backenduser WHERE tx_extbase_domain_model_backenduser.uid = '11' LIMIT 1
debug_backtrace    TYPO3\CMS\Extbase\Core\ModuleRunner->callModule#47 // TYPO3\CMS\Extbase\Core\Bootstrap->run#81 // TYPO3\CMS\Extbase\Core\Bootstrap->handleRequest#197 // TYPO3\CMS\Extbase\Mvc\Web\BackendRequestHandler->handleRequest#208 // TYPO3\CMS\Extbase\Mvc\Dispatcher->dispatch#47 // TYPO3\CMS\Extbase\Mvc\Controller\ActionController->processRequest#100 // TYPO3\CMS\Extbase\Mvc\Controller\ActionController->callActionMethod#186 // TYPO3\CMS\Fluid\View\AbstractTemplateView->render#325 // FluidCache_Belog_Tools_layout_DocHeader_c4779896192285f5aa3e33f083771beab2f4fccf->render#200 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->initializeArgumentsAndRender#80 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->callRenderMethod#237 // call_user_func_array#255 // TYPO3\CMS\Fluid\ViewHelpers\Be\ContainerViewHelper->render# // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->renderChildren#100 // {closure}#283 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->initializeArgumentsAndRender#65 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->callRenderMethod#237 // call_user_func_array#255 // TYPO3\CMS\Fluid\ViewHelpers\RenderViewHelper->render# // TYPO3\CMS\Fluid\View\AbstractTemplateView->renderSection#90 // FluidCache_Belog_Tools_action_index_1ed0100434a95bf6e6f8c2c4aede9a0f6c50e96f->section_4f9be057f0ea5d2ba72fd2c810e8d7b9aa98b469#240 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->initializeArgumentsAndRender#40 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->callRenderMethod#237 // call_user_func_array#255 // TYPO3\CMS\Fluid\ViewHelpers\RenderViewHelper->render# // TYPO3\CMS\Fluid\View\AbstractTemplateView->renderPartial#88 // FluidCache_Belog_Tools_partial_Content_555c622f2e8edd68dc1c4a93854846f9da48e1f8->render#296 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->initializeArgumentsAndRender#87 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->callRenderMethod#237 // call_user_func_array#255 // TYPO3\CMS\Fluid\ViewHelpers\RenderViewHelper->render# // TYPO3\CMS\Fluid\View\AbstractTemplateView->renderPartial#88 // FluidCache_Belog_Tools_partial_Content_LogEntries_49f25570a13ffb9830961a090206632563fdede1->render#296 // TYPO3\CMS\Fluid\ViewHelpers\ForViewHelper::renderStatic#3403 // {closure}#122 // TYPO3\CMS\Fluid\ViewHelpers\ForViewHelper::renderStatic#3395 // {closure}#122 // TYPO3\CMS\Fluid\ViewHelpers\ForViewHelper::renderStatic#3386 // {closure}#122 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->initializeArgumentsAndRender#2380 // TYPO3\CMS\Fluid\Core\ViewHelper\AbstractViewHelper->callRenderMethod#237 // call_user_func_array#255 // TYPO3\CMS\Belog\ViewHelpers\UsernameViewHelper->render# // TYPO3\CMS\Extbase\Persistence\Repository->findByUid#50 // TYPO3\CMS\Extbase\Persistence\Repository->findByIdentifier#242 // TYPO3\CMS\Extbase\Persistence\Generic\QueryResult->getFirst#273 // TYPO3\CMS\Extbase\Persistence\Generic\PersistenceManager->getObjectDataByQuery#132 // TYPO3\CMS\Extbase\Persistence\Generic\Backend->getObjectDataByQuery#140 // TYPO3\CMS\Extbase\Persistence\Generic\Storage\Typo3DbBackend->getObjectDataByQuery#232 // TYPO3\CMS\Core\Database\DatabaseConnection->sql_query#341 // TYPO3\CMS\Core\Database\DatabaseConnection->debug#988

using the Backend Admin Tools > Log module

When I truncate all the cf_ tables it doesn’t change a thing.

#8 Updated by Mathias Brodala over 6 years ago

The issue at hand seems to be that the ext_typoscript_setup.txt of Extbase is not loaded in the backend, thus the mapping of TYPO3\CMS\Extbase\Domain\Model\BackendUser to the be_users table is not defined. I for myself cannot reproduce this issue here, however.

And could someone please change the title of this issue please?

#9 Updated by Wolfgang Klinger over 6 years ago

Thanks for the hint, adding
<INCLUDE_TYPOSCRIPT: source="FILE:EXT:extbase/ext_typoscript_setup.txt">
in the root typoscript template did the trick

I wonder why this is not included automatically …

#10 Updated by Alexander Opitz over 6 years ago

  • Subject changed from tiresome.. to FILE:EXT:extbase/ext_typoscript_setup.txt not included by default
  • Is Regression set to No

#11 Updated by Alexander Opitz over 6 years ago

As I understand the problem it seams to be http://forge.typo3.org/issues/51234 please try the patch from there and give response to it.

#12 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF