Bug #52453

Backend / Uncaught exception 'RuntimeException' with message 'No settings detected. This usually happens if there is no frontend TypoScript template with root flag set. Please create one.'

Added by Wolfgang Klinger almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2013-10-02
Due date:
% Done:

0%

TYPO3 Version:
6.1
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This worked before for sure, but recently I get the following error message if I try to access the Admin > Log module in the backend:

Uncaught exception 'RuntimeException' with message 'No settings detected. This usually happens if there is no frontend TypoScript template with root flag set. Please create one.' in /usr/local/lib/typo3/typo3_src-6.1.4/typo3/sysext/belog/Classes/Controller/AbstractController.php:104
Stack trace:\n#0 [internal function]: TYPO3\\CMS\\Belog\\Controller\\AbstractController->initializeIndexAction()
#1 /usr/local/lib/typo3/typo3_src-6.1.4/typo3/sysext/extbase/Classes/Mvc/Controller/ActionController.php(177): call_user_func(Array)
#2 /usr/local/lib/typo3/typo3_src-6.1.4/typo3/sysext/extbase/Classes/Mvc/Dispatcher.php(100): TYPO3\\CMS\\Extbase\\Mvc\\Controller\\ActionController->processRequest(Object(TYPO3\\CMS\\Extbase\\Mvc\\Web\\Request), Object(TYPO3\\CMS\\Extbase\\Mvc\\Web\\Response))
#3 /usr/local/lib/typo3/typo3_src-6.1.4/typo3/sysext/extbase/Classes/Mvc/Web/BackendRequestHandler.php(47): TYPO3\\CMS\\Extbase\\Mvc\\Dispatcher->dispatch(Object(TYPO3\\CMS\\Extbase\\Mvc\\Web\\Request), Object(TYPO3\\CMS\\Extbase\\Mvc\\Web\\Response))
#4 /usr/local/ in /usr/local/lib/typo3/typo3_src-6.1.4/typo3/sysext/belog/Classes/Controller/AbstractController.php on line 104, referer: http://my-host/typo3/backend.php

Every other module and the website work fine
(the error message looks like a frontend related issue though)

Possibly related to issue 43365


Related issues

Related to TYPO3 Core - Bug #43365: Backend user Page error after Update to 6.0 Closed 2012-11-27
Related to TYPO3 Core - Bug #51546: FILE:EXT:extbase/ext_typoscript_setup.txt not included by default Closed 2013-08-30
Related to TYPO3 Core - Bug #51234: Exception with EXT:sys_note is installed Closed 2013-03-13

History

#1 Updated by Martin Holtz almost 6 years ago

  • Same issue here - but only on one page with two subpages. I did not find more pages with this error. And it worked before at this day!
  • I truncated all cf_cache_* tables without effect.
  • I used "SU" for switching to a different user did not work.
  • I have a TypoScript Template at the toplevel page, with root-flag set.
  • I created an new user and logged in with default language english.
  • I created a new Subpage, and got the error
  • i removed that subpage to another tree, i do not get the error.

Finally i realized, that on the page and the subpages where the error occurs, there is a typoscript template which deletes "module >". So, i removed that statement, and everything works as expected.

But i do not understand, why that worked before...

#2 Updated by Markus Klein almost 6 years ago

Looks like the configuration required for the extbase module is missing

#3 Updated by Philipp Gampe almost 6 years ago

  • Status changed from New to Needs Feedback

Some extensions uses the backend API to write log entries or triggers this at least. This needs a frontend TypoScript template. You should not delete the modules. key.

#4 Updated by Wolfgang Klinger almost 6 years ago

Philipp Gampe wrote:

Some extensions uses the backend API to write log entries or triggers this at least. This needs a frontend TypoScript template. You should not delete the modules. key.

Markus Klein wrote:

Looks like the configuration required for the extbase module is missing

So what’s the solution? What’s missing suddenly (as said before it already worked)?
There’s a frontend template, the website is online.

The copy on the development server (same setup) works as expected by now,
my problem is not related to the mentioned module > issue above imho

#5 Updated by Wolfgang Klinger almost 6 years ago

I fixed this problem for me by adding

<INCLUDE_TYPOSCRIPT: source="FILE:EXT:beuser/Configuration/TypoScript/setup.txt">
module.tx_beuser {
        persistence {
                classes {
                        TYPO3\CMS\Beuser\Domain\Model\BackendUser {
                                mapping {
                                        tableName = be_users
                                        columns {
                                                username.mapOnProperty = userName
                                        }
                                }
                        }
                }
        }                                                                
}
<INCLUDE_TYPOSCRIPT: source="FILE:EXT:belog/Configuration/TypoScript/setup.txt">

manually in the main Typoscript Template

#6 Updated by Alexander Opitz almost 6 years ago

As I understand the problem it seams to be http://forge.typo3.org/issues/51234 please try the patch from there and give response to it.

#7 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF