Project

General

Profile

Actions

Task #51930

closed

Task #49162: Rewrite install tool

install tool database data step should show query errors

Added by Christian Kuhn almost 11 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Category:
Install Tool
Target version:
Start date:
2013-09-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
hard
Sprint Focus:

Description

Installation process DatabaseData step should show possible DB errors (as flash message?)

Background is that we had a regression with #51929 leading to a not created sys_file table during installation. This is a hard query error, it should be possible to detect this and it should be shown.

Fix may be "hard" since a patch needs to be applied to SchemaMigratorService?


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #51929: Creation of sys_file-table fails due to incorrect keyClosed2013-09-12

Actions
Related to TYPO3 Core - Bug #63290: MySQL rights installtoolClosed2014-11-24

Actions
Related to TYPO3 Core - Bug #69777: Install Tool crashes with `#1341397869: Path does not exist in array`ClosedAnja Leichsenring2015-09-14

Actions
Actions

Also available in: Atom PDF