Feature #52876

Epic #55575: Streamline JavaScript Code in the TYPO3 Backend

Replace ExtJS Tree with jquery tree to get rid of extjs

Added by Kay Strobach about 8 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2013-10-16
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.3
Tags:
Complexity:
medium
Sprint Focus:

Description

concerns: web -> tree, tca tree

http://www.jstree.com/

Alternativly use e.g. sth similar


Related issues

Related to TYPO3 Core - Task #56970: Category-tree needs to load in parts (AJAX?)Closed2014-03-16

Actions
Is duplicate of TYPO3 Core - Feature #76108: Refactor Category tree to be based on SVGClosedTymoteusz Motylewski2016-05-10

Actions
#1

Updated by Ingo Renner about 8 years ago

AFAIR jsTree is used by the Neos team, too. Should be a good choice...

#2

Updated by Kay Strobach about 8 years ago

mhmm, but does only make sense with the noticed refactoring of the backend.php output ... hopefully i find the time for 6.3 :D

#3

Updated by Daniel Siepmann over 7 years ago

  • Parent task set to #55575
#4

Updated by Mathias Schreiber almost 7 years ago

  • Target version changed from 7.0 to 7.1 (Cleanup)
#5

Updated by Benni Mack over 6 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)
#6

Updated by Susanne Moog about 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#7

Updated by Benni Mack about 6 years ago

  • Target version changed from 7.5 to 8 LTS
#8

Updated by Riccardo De Contardi over 5 years ago

  • Category set to Backend User Interface
#9

Updated by Benni Mack about 5 years ago

  • Status changed from New to Closed

Fixed in #76108

Also available in: Atom PDF