Task #56341

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Bug #52949: Speed decrease since 4.5

Bug #56307: Findings from Bootstrap/PackageManager/ClassLoader analyses

Evaluate if it is really reasonable to have TYPO3\CMS\Core\Compatibility\LoadedExtensionsArray

Added by Steffen Ritter over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Category:
Performance
Target version:
-
Start date:
2014-02-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

could be build once as array, put to PackageManager_HASH and just restored


Related issues

Is duplicate of TYPO3 Core - Task #56538: Cache the $GLOBALS['TYPO3_LOADED_EXT'] as an arrayClosedThomas Maroschik2014-03-04

Actions
#1

Updated by Thomas Maroschik over 8 years ago

  • Status changed from New to Accepted
  • Assignee set to Thomas Maroschik
#2

Updated by Ernesto Baschny over 8 years ago

  • Tracker changed from Bug to Task
  • Category set to Performance
  • Status changed from Accepted to Closed

Sorry, I opened a duplicate for this (#56538), haven't noticed this one before (due to it's subject). I close this one, because I wrote some more in my own. :) Tom will take a look at it!

#3

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Closed to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28329

#4

Updated by Gerrit Code Review over 8 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28329

#5

Updated by Gerrit Code Review over 8 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28329

#6

Updated by Thomas Maroschik over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Steffen Ritter over 8 years ago

  • Status changed from Resolved to Accepted
  • % Done changed from 100 to 0
#8

Updated by Helmut Hummel over 8 years ago

  • Status changed from Accepted to Needs Feedback
  • Assignee changed from Thomas Maroschik to Steffen Ritter

Isn't this resolved now?
@Steffen: Why did you reopen it?

#9

Updated by Stephan Großberndt almost 8 years ago

Can this issue be closed?

#10

Updated by Mathias Schreiber over 7 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF