Bug #56418

Missing margin/padding on content element fields

Added by Mathias Brodala over 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2014-03-16
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Editing a content element in the backend currently shows some fields without margin/padding:

ce-fields-padding.png View (6.26 KB) Mathias Brodala, 2014-02-28 10:12


Subtasks

Bug #57211: ExtJS / normalize table thClosed

Bug #56950: Additional margin on top of ExtJS context menusClosedErnesto Baschny


Related issues

Related to TYPO3 Core - Task #55316: Upgrade normalize.css to version 3.0.0 Closed 2014-01-24
Duplicated by TYPO3 Core - Bug #56567: Palette form fields have no left padding anymore Closed 2014-03-05

Associated revisions

Revision f3dc10b0 (diff)
Added by Ernesto Baschny over 5 years ago

[BUGFIX] Remove ExtJS normalization

To avoid conflicts with normalize.css, we remove the normalization done by
ExtJS, which is loaded after the normalize.css now.

Resolves: #56418
Releases: 6.2
Change-Id: I8a5b633244c5074755d478d0497b8f438ef86b65
Reviewed-on: https://review.typo3.org/28069
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Felix Kopp
Tested-by: Felix Kopp
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind
Reviewed-by: Frans Saris
Tested-by: Frans Saris

History

#1 Updated by Markus Klein over 5 years ago

  • Status changed from New to Accepted
  • Assignee set to Felix Kopp
  • Is Regression changed from Yes to No

#2 Updated by Mathias Brodala over 5 years ago

Do you care to explain why this is not a regression? It did look fine before and does not anymore now.

#3 Updated by Markus Klein over 5 years ago

  • Is Regression changed from No to Yes

Of course it is, sorry for that.

#4 Updated by Ernesto Baschny over 5 years ago

The problem is the new order of loading of the CSS files.

normalize now comes before ext-all-notheme, where the margin:0/padding:0 is set for many elements (including fieldset). This used to be the other way around.

The problem is that ext-all-notheme also contains his own "reset" CSS (line 21) which now takes precedence over normalize (as it overwrites it).

What to do?

Easiest and most backwards compatible way would be to switch them around again (loading ext-all-notheme as a "library" even before normalize) to get back the old behaviour.

#5 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28069

#6 Updated by Ernesto Baschny over 5 years ago

  • Status changed from Under Review to Accepted

#7 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28069

#8 Updated by Gerrit Code Review over 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28069

#9 Updated by Gerrit Code Review over 5 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28069

#10 Updated by Felix Kopp over 5 years ago

  • Status changed from Under Review to Resolved

#11 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF