Story #58777

Fixes/Tasks for impexp / distributions

Added by Marc Bastian Heinrichs almost 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Import/Export (T3D)
Target version:
-
Start date:
2014-03-26
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
TYPO3 Version:
6.2
PHP Version:
Tags:
Sprint Focus:

Description

An umbrella issue for fixes in impexp regarding creating and using distributions.

PLEASE do not comment here! Thx!


Subtasks

Task #58761: Check and use current hash and size on export to prevent errors on import.ClosedMarc Bastian Heinrichs2014-05-13

Actions
Task #58682: Impexp: use created Folder object for image addingClosedMarc Bastian Heinrichs2014-05-09

Actions
Task #58688: exec_SELECTgetSingleRow could also return FALSEClosedMarc Bastian Heinrichs2014-05-09

Actions
Task #57348: Introduction package does not install/load any pages: typo3 6.2.0ClosedNicole Cordes2014-03-26

Actions
Task #58782: Add signal in ImportExportUtility for importer modificationsClosedMarc Bastian Heinrichs2014-05-13

Actions
Task #58798: Log errors after distribution t3d import also, if pages was created.ClosedMarc Bastian Heinrichs2014-05-14

Actions
Task #58826: Prevent error message for correct imports of sys_file_metadataClosedMarc Bastian Heinrichs2014-05-15

Actions
Task #58841: Fix file imports to fallback storage 0ClosedMarc Bastian Heinrichs2014-05-15

Actions
Task #58843: Fix imports for fields of type input with link wizardClosedMarc Bastian Heinrichs2014-05-15

Actions
Task #58824: Impexp: add test for importing with forced uidsClosedMarc Bastian Heinrichs2014-05-15

Actions
Task #58912: Raise maximum settable numbers of exportClosedMarc Bastian Heinrichs2014-05-19

Actions
Task #59015: Catch all errors on adding files of sys_files to exportClosedMarc Bastian Heinrichs2014-05-21

Actions
Task #59154: Detect and import XML file as well as t3dClosedMarc Bastian Heinrichs2014-05-27

Actions
Task #59616: Import forces pid 0 if rootLevel = -1 is set in TCAClosedMarc Bastian Heinrichs2014-06-16

Actions

Related issues

Related to TYPO3 Core - Story #57377: Additional improvements for impexpClosed2014-03-27

Actions
#1

Updated by Katja Lampela almost 7 years ago

While trying to use export in root page (to export backend user settings) I get error after clicking "Export to .t3d":

Oops, an error occurred!
Error while fetching permissions for /var/www/vhosts/mysite/httpdocs/uploads/tx_imagecarousel/image.jpg

TYPO3 6.2.2

#2

Updated by Armin Vieweg almost 7 years ago

Yes, I can confirm Katja's issue.

This seems to happen because eg. the identifier "/htdocs" in TYPO3\CMS\Core\Resource\Driver\LocalDriver::getAbsolutePath() returns "/var/www/vhosts/.../htdocs/htdocs" and this folder does not exist of course.

#3

Updated by Armin Vieweg almost 7 years ago

After further investigation, I think the problem is the entry existing in sys_file which has always the identifier "/lastPartOfHtdocs". I think this should be just "/"? When I delete it and run the scheduler task, it will be created again.

#4

Updated by Marc Bastian Heinrichs almost 7 years ago

Since this is an umbrella issue only, please don't add more comments to this issue. Please create extra issues. Thx

Exporting sys_file records needs a very clean file index at the moment. Means for example no missing files, clean relations between elements using sys_file_reference and the sys_file_reference records and sys_file records.
I added an issue to suggest more reports for FAL to check this problems: #58764

Katja, your problem should be fixed with #59015. I will add a patch there that you could test, please.

Armin, to me it look like a very strange storage configuration. Better continue on mailing list. typo3.dev for example? Ping me with PM on Twitter, when you posted a msg.

#5

Updated by Marc Bastian Heinrichs almost 7 years ago

  • Subject changed from Fixes/Tasks for impexp / distributions to Fixes/Tasks for impexp / distributions (
  • Status changed from New to Accepted
  • Assignee set to Marc Bastian Heinrichs
#6

Updated by Marc Bastian Heinrichs almost 7 years ago

  • Subject changed from Fixes/Tasks for impexp / distributions ( to Fixes/Tasks for impexp / distributions
#7

Updated by Anja Leichsenring about 5 years ago

  • Parent task set to #72584
#8

Updated by Anja Leichsenring about 5 years ago

  • Status changed from Accepted to Resolved
#9

Updated by Anja Leichsenring about 5 years ago

  • Parent task deleted (#72584)
#10

Updated by Anja Leichsenring about 5 years ago

  • Sprint Focus set to On Location Sprint
#11

Updated by Mathias Schreiber almost 5 years ago

  • Sprint Focus deleted (On Location Sprint)
#12

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF