Bug #61377

Epic #58282: Workspaces Workpackage #2

Story #60008: Visual enhancements

Workspace Preview slider does not scale properly

Added by David Benjamin about 7 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2014-09-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

  1. Select a workspace to preview.
  2. Scale the window, notice the slider does not scale.

I am using Mozilla Firefox Web Browser ESR, Version 24 on openSuSE 13.1.

See the attached screenshot.


Files

WorkspaceError2.jpg (103 KB) WorkspaceError2.jpg Slider is over the Workspace tab. David Benjamin, 2014-09-05 16:27
WorkspaceError5.jpg (6.87 KB) WorkspaceError5.jpg David Benjamin, 2014-09-22 17:59
Schermata 2016-07-30 alle 19.44.46.png (34 KB) Schermata 2016-07-30 alle 19.44.46.png Riccardo De Contardi, 2016-07-30 19:46

Related issues

Related to TYPO3 Core - Bug #61374: Workspace Preview unusable due to sizeClosed2014-09-05

Actions
Related to TYPO3 Core - Bug #44745: Slider split preview uses only part of the available heightClosed2013-01-23

Actions
Related to TYPO3 Core - Bug #58441: Displaced button in workspace preview toolbarClosed2014-05-03

Actions
#1

Updated by Lorenz Ulrich about 7 years ago

In my case the problem is that 'document.domain' in the iFrames is empty (not in the parent frame). This makes the browser fail.

In PreviewController->indexAction the "backendDomain" is evaluated like this:

$this->view->assign('backendDomain', GeneralUtility::getIndpEnv('TYPO3_HOST_ONLY'));

In TypoScriptFrontendControllerHook->hook_eofe it is done like this:

'backendDomain.' => array('value' => $GLOBALS['BE_USER']->getSessionData('workspaces.backend_domain'))

In my case, the backend_domain from the session data is empty. When I change it to

'backendDomain.' => array('value' => \TYPO3\CMS\Core\Utility\GeneralUtility::getIndpEnv('TYPO3_HOST_ONLY'))

it works. I don't understand why in the latter case sessionData is used and in the first case the environment variables.

#2

Updated by Oliver Hader almost 7 years ago

  • Status changed from New to Accepted
  • Parent task set to #60008

I agree, the visual components look "ugly" and do not respond to changed screen sizes..

#3

Updated by David Benjamin almost 7 years ago

I applied the patches in from issue #61699. It fixed issue #61374 but not this one.

I have attached a screen shot.

#4

Updated by Mathias Schreiber over 6 years ago

  • Target version set to 7.5
#5

Updated by Oliver Hader almost 6 years ago

  • Target version changed from 7.5 to 7 LTS
  • Complexity set to hard
#6

Updated by Mathias Schreiber almost 6 years ago

  • Target version deleted (7 LTS)
#7

Updated by Riccardo De Contardi about 5 years ago

the problem is still present on TYPO3 7.6.10 but is absent on 8.3-dev (latest master);

The only problem I see so far in master is that the label "live" goes under the tabs (see attached screenshot Schermata 2016-07-30 alle 19.44.46.png)

#8

Updated by Christian Kuhn over 4 years ago

  • Status changed from Accepted to Rejected

i guess we will not solve that in v7 anymore.

Also available in: Atom PDF