Bug #44745

Slider split preview uses only part of the available height

Added by Jigal van Hemert over 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2013-01-23
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

It's already been mentioned in http://forge.typo3.org/issues/11539#note-5 but in current versions of many browser the slider split preview will only use a small part of the screen in certain cases.
It seems that JS errors/warnings prevent the iframes from using the full height of the browser and they are displayed with only approximately 150px height (as noticed in http://forge.typo3.org/issues/11539#note-11 ).
Tested on Windows Vista the following browsers were tried:
- Chrome: displayed full height of browser
- Firefox, Opera: only 150px
- IE9 : only 150px plus the slider couldn't be dragged

Screenshot: see http://forge.typo3.org/attachments/4799/comparison_view_ff36_mac.png (from issue #11539)


Related issues

Related to TYPO3 Core - Bug #11539: Split view Closed 2010-12-17
Related to TYPO3 Core - Bug #61374: Workspace Preview unusable due to size Closed 2014-09-05
Related to TYPO3 Core - Bug #61377: Workspace Preview slider does not scale properly Rejected 2014-09-05
Related to TYPO3 Core - Bug #41629: TYPO3-Workspaces height of iframe to small New 2012-10-05

History

#1 Updated by Oliver Hader over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version set to 4.5.23

Do you have a stack trace of the mentioned JavaScript error available. I'm still wondering why a problem inside an IFrame causes the parent frames/documents to have issues as well.

#2 Updated by Hercules Karvasonis about 6 years ago

I am also able to reproduce that on latest TYPO3 4.7.12.

I followed those steps:
- Clicked on the Workspace module
- Generated a preview link
- Viewed the page with that link
- Opened the page from within the backend with the slider view and the height is very small.
In this case if i delete the "ADMCMD_prev" cookie then the page with the slider loads correctly.

Did anyone else find any way to reproduce that or fix it?

#3 Updated by Sven Proffe over 5 years ago

Did anyone else find any way to reproduce that or fix it?

It's reliably reproduceable on TYPO3 6.1.6. Obviously not fixed yet. Could someone set this issue to "Must have"? This error is pretty annoying and quite unexplainable to editors.

BTW: The Live view throws this error:

Fatal error: Call to a member function getSessionData() on a non-object in typo3/sysext/workspaces/Classes/Hook/TypoScriptFrontendControllerHook.php on line 49

Seems to me, that this is responsible for the bug.

Thanks & regards
Sven

#4 Updated by Michael Stucki over 5 years ago

  • Category changed from Bugs to Workspaces

#5 Updated by Michael Stucki over 5 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#6 Updated by Alexander Opitz over 5 years ago

  • Is Regression set to No

@Hercules Karvasonis

your issue sounds more like http://forge.typo3.org/issues/18761

#7 Updated by Thomas Sperling over 5 years ago

I have the same issue. I researched and found out the problem is that backendDomain is not set in the IFrame. So you got in the parent 'document.domain = "xyz.domain.de"' and in the IFrame 'document.domain = ""'.

A similiar problem is maybe related: http://forge.typo3.org/issues/30643

#8 Updated by Alexander Opitz about 5 years ago

  • Status changed from Needs Feedback to New
  • Target version deleted (4.5.23)

#9 Updated by Hercules Karvasonis over 4 years ago

Alexander,

i tried the fix from issue #18761 and it is not working.
I can still experience the issue as i described it above.

Thanks,
Hercules Karvasonis.

#10 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.5

#11 Updated by Oliver Hader almost 4 years ago

  • Target version changed from 7.5 to 8 LTS
  • Complexity set to hard

#12 Updated by Benni Mack about 2 years ago

  • Target version changed from 8 LTS to next-patchlevel

#13 Updated by Riccardo De Contardi about 2 years ago

  • Related to Bug #41629: TYPO3-Workspaces height of iframe to small added

#14 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from New to Closed
  • Target version deleted (next-patchlevel)

I close this one in favor of #41629 please continue the discussion there.

If you think that this is the wrong decision, please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF