Bug #62767

Missing function to clear processed images (FAL image cache)

Added by Christian Ludwig almost 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2014-11-07
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

There is no functionality in TYPO3 6.2 that allows to clear the new image cache (processed folders in typo3temp and file storages + sys_file_processedfile database table).

To clear the table a function exists in the Upgrade Wizard, but it is not available after completing a migration and it does not delete the files on file storages, so there are lots of files left without reference (do they get deleted someday?).

In addition:
A "trigger" to delete processed files (i. e. a hook in the core "clear cache" function) should be available in every FAL Driver like S3 and so on.


Related issues

Related to TYPO3 Core - Bug #64556: ProcessedFile record should not be saved/created when processing failed Closed 2015-01-28
Related to TYPO3 Core - Task #67071: Add cleanup tool for processed files to Install Tool Closed 2015-05-21

History

#1 Updated by Ingo Schmitt almost 5 years ago

  • Status changed from New to Needs Feedback

Hello Christian,

if you just delete the processed files, you would end up in a frontend with missing images, since the frontend would deliver cached pages with image references. Thus the page cache must also be cleared.

Can you provide a use case, why the already generated images should be cleared by a backend task (Besides of cleaning this directory)?

#2 Updated by Christian Ludwig almost 5 years ago

You are right, the page cache should be cleared too.
The reason why a clear cache function for FAL is needed are the same as they are for the old image system.

Some of the reasons are:
  • Clean up unneeded image sizes (i. e. when image size was globally changed by TypoScript setting)
  • Clean up database an file system from all temp data before backups
  • Clean up temp files, when original images got deleted by external process (WebDAV, rsync, ...)
  • Problems with bugs in current FAL version (i. e. change image file by FTP or other application, wrong image sizes, ...)

#3 Updated by Bernhard Kraft over 4 years ago

I provided reasons for adding a possibility to clear sys_file_processedfiles in the issue I related to this one.

#4 Updated by Christian Ludwig over 4 years ago

Ingo Schmitt wrote:

Can you provide a use case, why the already generated images should be cleared by a backend task (Besides of cleaning this directory)?

Feedback was given, can anyone please change the status of this issue? Thanks.

#5 Updated by Geddo no-lastname-given over 4 years ago

+1 This is def. a must have!
While i'm messing around with many images while developing a website i would love to have a "RefreshAllProcessedImages"-Button do replace the placeholders with the final content

#6 Updated by Felix Nagel over 4 years ago

I think I've got another use case:

When changing the FAL image names (e.g. for SEO reasons) it seems there is no way to force a re-rendering of the cached processed images. Or do I miss something?

#7 Updated by Alexander Köberl over 4 years ago

another use-case: we have extensions importing data and images from foreign sources. changed images are updated on every import in uploads/tx_****/, but the new typo3temp/_processed_/ imagecache is ignoring these image updates.

#8 Updated by Steffen Roßkamp about 4 years ago

There also seems to be an issue when using the replace file function. The system still uses the old file until some time later.

#9 Updated by Alexander Opitz about 4 years ago

  • Status changed from Needs Feedback to New
  • Target version changed from next-patchlevel to 7.5

#10 Updated by Benni Mack about 4 years ago

  • Target version changed from 7.5 to 7 LTS

#11 Updated by Christian Kuhn almost 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

this was solved in 6.2 and 7 with a clean-up option within the install tool.

#12 Updated by Marc Blasig almost 4 years ago

Is it possible to enable this feature within the "Clear cache" dropdown for non-administrator backend users? We have the same issue as #7 on a regular basis and would like to perform the clean-up from within the normal TYPO3 backend.

Also available in: Atom PDF