Bug #65728

Call to a member function wrapClickMenuOnIcon() on a non-object

Added by Kurt Gusbeth over 6 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
System/Bootstrap/Configuration
Target version:
-
Start date:
2015-03-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I get this error message in my backend module:

Fatal error: Call to a member function wrapClickMenuOnIcon() on a non-object in /var/www/html/typo3_src-7.1.0/typo3/sysext/recordlist/Classes/RecordList/DatabaseRecordList.php on line 721

when I use this fluid script:
<f:be.tableList tableName="tx_camaliga_domain_model_content" 
     fieldList="{0: 'title', 1: 'shortdesc'}" storagePid="{pid}" levels="0" sortField="title" 
     readOnly="true" enableClickMenu="true" clickTitleMode="info" alternateBackgroundColors="true" />

It works in Typo3 6.2, but not in Typo3 7.1.


Related issues

Related to TYPO3 Core - Bug #70494: AbstractFormElement opening IRRE via ajax fails if it contains thumbnails because $GLOBALS['SOBE'] is not setClosed2015-10-08

Actions
#1

Updated by Markus Bischof over 6 years ago

+1

If you set enableClickMenu to false the table is renderd - but without the buttons to edit or modify records.

Markus

#2

Updated by Markus Bischof over 6 years ago

After some debugging I'm one step further.
The problem seems to be the function getModule in sysext/recordlist/Classes/RecordList/DatabaseRecordList.php. This function is called in line 721 in the same Class when building the list with the option clickMenuEnabled.

The problem is that getModule returns $GLOBALS['SOBE'] which was removed in TYPO3 CMS 7.0 (http://wiki.typo3.org/TYPO3_CMS_7.0)

Markus

#3

Updated by Kurt Gusbeth over 6 years ago

OK, I have set enableClickMenu to false...

#4

Updated by Benni Mack over 6 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)
#5

Updated by Susanne Moog about 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#6

Updated by Benni Mack almost 6 years ago

  • Target version changed from 7.5 to 7 LTS
#7

Updated by Benni Mack almost 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (7 LTS)

can you recheck again with current master again, please?

#8

Updated by Kurt Gusbeth almost 6 years ago

I dont know how to install the lastest TYPO3 version. When I do it like described here:
https://wiki.typo3.org/Clone_%28Git%29
I get only an error:
Warning: require(/var/www/html/TYPO3.CMS/typo3/../vendor/autoload.php): failed to open stream: No such file or directory in /var/www/html/TYPO3.CMS/typo3/index.php on line 19

#9

Updated by Kurt Gusbeth almost 6 years ago

I cant test it with the TYPO3 7.5.0, because that version doesnt run. I always get errors like this:

#1253036401: Argument "condition" has already been defined, thus it should not be defined again. (More information)

TYPO3\CMS\Fluid\Core\ViewHelper\Exception thrown in file
/var/www/html/typo3_src-7.5.0/typo3/sysext/fluid/Classes/Core/ViewHelper/AbstractViewHelper.php in line 174.

or
Property TYPO3\CMS\Extensionmanager\Service\ExtensionManagementService::$listUtility does not exist

ReflectionException thrown in file
/var/www/html/typo3_src-7.5.0/typo3/sysext/core/Classes/Utility/GeneralUtility.php in line 4348.

#10

Updated by Kurt Gusbeth almost 6 years ago

I have tried this now:

wget get.typo3.org/dev --content-disposition

TYPO3 runs, but I still get the error message:
Fatal error: Call to a member function wrapClickMenuOnIcon() on a non-object in /xxx/typo3conf/ext/gridelements/Classes/Xclass/DatabaseRecordList.php on line 1010

#11

Updated by Kurt Gusbeth almost 6 years ago

And when uninstalling gridelements:

Fatal error: Call to a member function wrapClickMenuOnIcon() on a non-object in /var/www/html/typo3_src-7.5.0/typo3/sysext/recordlist/Classes/RecordList/DatabaseRecordList.php on line 745

#12

Updated by Claus Due almost 6 years ago

  • Category changed from Fluid to 1599

The remaining problems are caused by gridelements replacing classes, likely combined with TYPO3 not being able to completely flush caches because of that issue. Manually flushing all caches should solve that.

For additional help with the composer based install of TYPO3 7.5.0 (and future versions too) I suggest checking the updated install instructions. Essentially, you do "composer install" and it creates the vendor dir you're missing. And of course don't hesitate to use the forums or chats for a more "live" help from other users to install 7.5.0 ;)

#13

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/44139

#14

Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/44139

#15

Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/44139

#16

Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/44139

#17

Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/44139

#18

Updated by Kurt Gusbeth almost 6 years ago

I have tested now the 2 patches and it works now.
Well done!

#19

Updated by Claus Due almost 6 years ago

  • Status changed from Under Review to New

Sorry Kurt, I had to abandon the patch so I'm not sure what the situation is.

The proposed patch I created was called "ugly" so I'm definitely not going to attempt a second one.

#20

Updated by Christian Kuhn almost 6 years ago

The wrapClickMenuOnIcon() fatal was solved with #70494, issueCommand() will still give headaches, though.
I guess it should be tackled in a similar way, the method is similar "static" as the first one and there is little reason to not move it over to BackendUtility next the other little helper methods that live there already. This would then free DatabaseRecordList from its dependency to DocumentTemplate altogether as far as i can see, and thus the problem vanishes.

#21

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44329

#22

Updated by Jan Helke almost 6 years ago

The patch deals with issueCommand in the way as Christian proposed. Together with his already merged patch, it should solve this issue.

#23

Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44329

#24

Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44329

#25

Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44329

#26

Updated by Jan Helke almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#27

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF