Project

General

Profile

Actions

Bug #66085

closed

file link could not be modified anymore

Added by Roland Reichenauer almost 9 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2015-03-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Trying to modify an existing file link (class=”download”) the modifying dialog roots to card index “External URL” an not to “File”. In all further versions up to 6.2.10 the modifying dialog run correct and there was an update button. Shifting manually from card index “External URL” to "File" this button is missing.


Files

Bildschirmfoto 2015-03-29 um 17.21.07.png (42.2 KB) Bildschirmfoto 2015-03-29 um 17.21.07.png Dialog when trying to edit an already set link to a FAL-file Stefan Völker, 2015-03-29 17:21

Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Story #66051: changing linksClosed2015-03-26

Actions
Related to TYPO3 Core - Bug #65358: file://* links not accessibleClosedNicole Cordes2015-02-26

Actions
Related to TYPO3 Core - Bug #66243: File links in RTE don't get counted as a reference since TYPO3 6.2.11ClosedNicole Cordes2015-04-02

Actions
Actions #1

Updated by Rafal Brzeski almost 9 years ago

I can confirm this issue, it appeared after update from 6.2.9 to 6.2.11.
There is another issue which I think may be connected with that one. In Filelist module references to files linked by RTE are missed.

Actions #2

Updated by Stefan Völker almost 9 years ago

I also can confirm that on 6.2.11
The links are interpreted right in the frontend, but in the RTE they are not recognized as FAL-Links anymore...

Actions #3

Updated by Wouter Wolters almost 9 years ago

  • Status changed from New to Accepted
Actions #4

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38383

Actions #5

Updated by Gerrit Code Review almost 9 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38383

Actions #6

Updated by Gerrit Code Review almost 9 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38383

Actions #7

Updated by Gerrit Code Review almost 9 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38385

Actions #8

Updated by Wouter Wolters almost 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Martina Ahlswede almost 9 years ago

Even with the current 6.2.12 there still is the problem described in Bug #66243, means the problem with the wrong link is solved: File links are interpreted as file links again and not as external links, but there is still the problem, that no reference in the fileadmin is created. Can you please check if this is related and if it can be fixed?

Actions #10

Updated by Tobias Schaefer almost 9 years ago

It's bug #66243 not #6624

Actions #11

Updated by Martina Ahlswede almost 9 years ago

Thanks, I changed the link.

Actions #12

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF