Bug #66587

Scheduler serialized task needs to be migrated for 7.x

Added by Xavier Perseguers over 6 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Could have
Category:
scheduler
Target version:
-
Start date:
2015-04-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Fatal error: TYPO3\CMS\Scheduler\Controller\SchedulerModuleController::listTasksAction(): The script tried to execute a method or
access a property of an incomplete object. Please ensure that the class definition "tx_scheduler_Execution" of the object you
are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in
/path/to/typo3/sysext/scheduler/Classes/Controller/SchedulerModuleController.php on line 1043

Problem is with this PHP block:

// Get execution type
if ($task->getExecution()->getInterval() == 0 && $task->getExecution()->getCronCmd() == '') {
    $execType = $this->getLanguageService()->getLL('label.type.single');
    $frequency = '-';
} else {
    $execType = $this->getLanguageService()->getLL('label.type.recurring');
    if ($task->getExecution()->getCronCmd() == '') {
        $frequency = $task->getExecution()->getInterval();
    } else {
        $frequency = $task->getExecution()->getCronCmd();
    }
}

This fails since $task->getExecution() is an incomplete PHP task:

The serialized task object is:

O:37:"Causal\IgLdapSsoAuth\Task\ImportUsers":10:{s:10:"*context";s:4:"both";s:16:"*configuration";i:0;s:23:"*missingUsersHandling";s:7:"nothing";s:24:"*restoredUsersHandling";s:7:"nothing";s:10:"*taskUid";i:7;s:11:"*disabled";b:1;s:12:"*execution";O:29:"TYPO3\CMS\Scheduler\Execution":6:{s:8:"*start";i:1424099520;s:6:"*end";i:1424099520;s:11:"*interval";i:0;s:11:"*multiple";i:0;s:10:"*cronCmd";s:0:"";s:23:"*isNewSingleExecution";b:0;}s:16:"*executionTime";i:1424099520;s:14:"*description";s:0:"";s:12:"*taskGroup";N;}

Files

incomplete.png (119 KB) incomplete.png Xavier Perseguers, 2015-04-25 14:12

Related issues

Related to TYPO3 Core - Bug #84973: Cannot delete invalid Scheduler taskClosed2018-05-11

Actions

Also available in: Atom PDF