Bug #66912

There is something wrong while creating pages in pagetree

Added by Stefan Froemken over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
Start date:
2015-05-12
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Hello Core-Team,

if I create a new page with help of the drag 'n drop feature in pagetree I normally can change the page title immediatly. But on current master some JS does not jump into edit mode just after creating a page anymore.

Then we have another bug:

If I select a page it works. But if you click on that selected page again you are directly in edit page title mode. So, to load that page again, I have to click on another page first and than click back on previous page again.

I just have asked Benjamin Kott if this is a new feature or a bug and it seems to be a regression.

Stefan


Related issues

Related to TYPO3 Core - Bug #63591: Improve page tree performance Closed 2014-12-05
Related to TYPO3 Core - Bug #67322: 2nd click on active page does not force reload Closed 2015-06-05

Associated revisions

Revision e0fe5c0a (diff)
Added by Frank Naegler over 4 years ago

Revert "[TASK] Massive performance improvement for page tree"

This patch needs to be reverted, because of a regression with
the page tree and the double click behavior.

Releases: master
Resolves: #66912
Resolves: #67322
Reverts: #63591

This reverts commit a89d3765663c0ed05c8435ad767f106fa9d60bf8.

Change-Id: I35b9d80f25fa1f2f3951bf70bbbe9e02dafdc28d
Reviewed-on: http://review.typo3.org/40154
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Frank Nägler <>
Tested-by: Frank Nägler <>

History

#1 Updated by Wouter Wolters over 4 years ago

  • Assignee deleted (Benjamin Kott)

#2 Updated by Jigal van Hemert over 4 years ago

Can't reproduce the reported behaviour for creating new pages.

The issue with two separate clicks instead of a double-click is indeed present.

#3 Updated by Frank Naegler over 4 years ago

  • Status changed from New to Accepted

#4 Updated by Gerrit Code Review over 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40154

#5 Updated by Frank Naegler over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF