Bug #63591

Improve page tree performance

Added by Helmut Hummel almost 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-12-05
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

To detect a double click to edit a page title the page tree
literally waits 400ms before it loads the content area.

besides that the loading mask suggests a not loaded page, while
most of the content is already there.

The latter should just be dropped. It was iirc only included to
not break pure extjs modules while not completely initialized.

For the first, we need an alternative to easily edit page titles inline


Related issues

Related to TYPO3 Core - Bug #25435: Option to disable the loading mask Rejected 2011-03-29
Related to TYPO3 Core - Bug #66912: There is something wrong while creating pages in pagetree Closed 2015-05-12
Related to TYPO3 Core - Bug #67322: 2nd click on active page does not force reload Closed 2015-06-05
Related to TYPO3 Core - Feature #82426: Replace ExtJS page tree with SVG one Closed 2017-09-09

Associated revisions

Revision a89d3765 (diff)
Added by Frank Naegler over 4 years ago

[TASK] Massive performance improvement for page tree

This patch improves the performance by removing delays.

A single click in the tree loads the page now significantly faster, however,
the page is now loaded also with a doubleclick.

With a tree implementation without ExtJS we can change this behavior again.

Resolves: #63591
Releases: master
Change-Id: I4e32013d2d904e1cc4f91f8c9fa9af165fc8c476
Reviewed-on: http://review.typo3.org/39382
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Benjamin Mack <>
Tested-by: Benjamin Mack <>

History

#1 Updated by Gerrit Code Review almost 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35067

#2 Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35067

#3 Updated by Gerrit Code Review over 4 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39382

#4 Updated by Frank Naegler over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Frank Naegler over 4 years ago

  • Status changed from Resolved to Accepted

because of a regression, this patch will be reverted. For more information look at #66912 and #67322

#6 Updated by Frank Naegler over 4 years ago

  • Status changed from Accepted to Resolved

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40154

Applied in changeset e0fe5c0a158b38cf509e90a328856d8105bebe73.

#7 Updated by Frank Naegler over 4 years ago

  • Status changed from Resolved to Accepted
  • % Done changed from 100 to 0

#8 Updated by Riccardo De Contardi about 2 years ago

  • Related to Feature #82426: Replace ExtJS page tree with SVG one added

#9 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Accepted to Closed

This should become obsolete with the new SVG pagetree; I close it for now.

If you think that this is the wrong decision, feel free to reopen it.

Also available in: Atom PDF