Feature #67372

Fluid Tag Builder: Allow empty attributes

Added by Sebastian Michaelsen over 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2015-06-09
Due date:
% Done:

100%

PHP Version:
Tags:
Complexity:
Sprint Focus:
Remote Sprint

Description

When using the Fluid Tag Builder to create tags an attribute can only be set as a key/value pair. It should be possible render attributes with the "empty attributes syntax" (http://www.w3.org/TR/html-markup/syntax.html#syntax-attributes).


Related issues

Related to TYPO3 Core - Bug #68474: Revert "Fluid Tag Builder: Allow empty attributes" Closed 2015-07-22

Associated revisions

Revision ee6f545a (diff)
Added by Sebastian Michaelsen about 4 years ago

[FEATURE] Fluid Tag Builder: Allow empty attributes

When using the Fluid Tag Builder to create tags an attribute can only be
set as a key/value pair. It should be possible render attributes with
the "empty attributes syntax".

http://www.w3.org/TR/html-markup/syntax.html#syntax-attributes

Releases: master
Resolves: #67372
Change-Id: Iae76f2eb82af79ad36e6a1f1d2485fa2070090df
Reviewed-on: http://review.typo3.org/40139
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40139

#2 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40139

#3 Updated by Benni Mack about 4 years ago

  • Target version set to 7.4 (Backend)
  • Sprint Focus set to On Location Sprint

#4 Updated by Gerrit Code Review about 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40139

#5 Updated by Gerrit Code Review about 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40139

#6 Updated by Gerrit Code Review about 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40139

#7 Updated by Anonymous about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Markus Klein about 4 years ago

  • Status changed from Resolved to Accepted

Patch was reverted. See #68474

#9 Updated by Susanne Moog about 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#10 Updated by Anja Leichsenring about 4 years ago

  • Sprint Focus changed from On Location Sprint to Remote Sprint

#11 Updated by Claus Due about 4 years ago

  • Status changed from Accepted to Resolved

Resolved (since then also reverted). Issue was not closed by bot. Closing now.

Must be reported to standalone Fluid for a solution there.

#12 Updated by Claus Due about 4 years ago

@Sebastian I hate to ask, but would you mind:

- Testing if this problem persists in standalone Fluid (the TagBuilder there comes from Flow and is more recent)
- If it persists, reporting the issue on the bug tracker there for us to solve it asap.

Thanks :)

https://github.com/TYPO3Fluid/Fluid

#13 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF