Bug #67838

Cannot instantiate HttpRequest

Added by Mathias Brodala over 2 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Must have
Category:
Miscellaneous
Target version:
Start date:
2015-06-30
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In the 7.x release line the HttpRequest class cannot be instantiated due to an upstream issue.

This should be fixed by bumping the dependency to a version which has a fix.


Related issues

Related to TYPO3 Core - Feature #70056: Use guzzle Resolved 2015-09-23
Related to Sphinx Documentation Viewer Plugin - Bug #75615: Composer Installation 7.6: Fatal error: require_once(): Failed opening required 'Net/URL2.php' Rejected 2016-04-14
Duplicated by TYPO3 Core - Bug #69207: Failing inclusion of PEAR class Net/URL2(.php) Closed 2015-08-20

Associated revisions

Revision be125fa1 (diff)
Added by Mathias Brodala over 2 years ago

[BUGFIX] Fix HttpRequest instantiation

This was fixed upstream but a new release was not
published yet, thus we temporarily require the commit
with the fix.

See https://github.com/pear/HTTP_Request2/pull/11

Resolves: #67838
Releases: master
Change-Id: Ie0dafce224c1ff4ee12587c503cfb649fbc8fd73
Reviewed-on: http://review.typo3.org/38898
Tested-by: Stefan Neufeind <>
Tested-by: Andreas Wolf <>
Reviewed-by: Stefan Neufeind <>
Reviewed-by: Andreas Wolf <>

Revision 47f89a05 (diff)
Added by Claus Due over 1 year ago

[TASK] Update pear/http_request2 dependency to version 2.3.0

Updates the mentioned dependency and accommodates new
differences in "include-paths" setting which is now included
directly from within the dependency. Preserving the previous
"include-path" setting breaks the inclusion completely.

NB: Must be followed up with patch to documentation download
which after this change will be incapable of downloading https
urls (e.g. zip files with documentation).

Change-Id: Ib06f44e6e1283aa6d5eb1dc0254005ef0eeb3f62
Resolves: #67838
Releases: 7.6
Reviewed-on: https://review.typo3.org/48692
Tested-by: TYPO3com <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38898

#2 Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38898

#3 Updated by Gerrit Code Review over 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38898

#4 Updated by Georg Ringer over 2 years ago

  • Sprint Focus set to Stabilization Sprint

#5 Updated by Mathias Brodala over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 50 to 100

#6 Updated by Markus Klein over 2 years ago

  • Status changed from Resolved to New

#7 Updated by Benni Mack over 2 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#8 Updated by Alexander Stehlik over 2 years ago

Same problem seems to be present for the Net_URL2 PEAR package, I opened a bug report: https://pear.php.net/bugs/bug.php?id=20932

See typo3_src/typo3/vendor/pear/http_request2/HTTP/Request2.php for example:

/**
 * A class representing an URL as per RFC 3986.
 */
require_once 'Net/URL2.php';

/**
 * Exception class for HTTP_Request2 package
 */
require_once 'HTTP/Request2/Exception.php';

#9 Updated by Mathias Brodala over 2 years ago

I'd expect these two to be exactly the same project.

#10 Updated by Alexander Stehlik over 2 years ago

Hmm, possible. But it is not fixed in the current master of Net_URL2:

https://github.com/pear/Net_URL2/blob/master/composer.json

In HTTP_Request2 the fix is at least in the master branch:

https://github.com/pear/HTTP_Request2/pull/8

#11 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43508

#12 Updated by Benni Mack over 2 years ago

  • Target version changed from 7.5 to 7 LTS
  • Sprint Focus deleted (Stabilization Sprint)

#13 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43508

#14 Updated by Benni Mack almost 2 years ago

this one is solved in master now ;)

#15 Updated by Benni Mack almost 2 years ago

I will keep this issue open, maybe the composer library finally releases a new version and we could fix it for v7

#16 Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48085

#17 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48085

#18 Updated by Christian Fries over 1 year ago

I just saw that the patch set was abandoned. So what's the idea? It would be nice to have documentations in backend back.

#19 Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48692

#20 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48692

#21 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48692

#22 Updated by Gerrit Code Review over 1 year ago

Patch set 4 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/48692

#23 Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50697

#24 Updated by Anonymous over 1 year ago

  • Status changed from Under Review to Resolved

#25 Updated by Riccardo De Contardi 4 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF