Project

General

Profile

Actions

Bug #67875

closed

tt_content categories field is not registered for all types

Added by Alexander Stehlik over 8 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Category:
Categorization API
Target version:
Start date:
2015-07-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

Currently the tt_content table gets its categories field by the install tool configuration value:

$GLOBALS['TYPO3_CONF_VARS']['SYS']['defaultCategorizedTables']

The problem here is that most of the content types are defined in Configuration/TCA/Overrides since #65922.

Since the Overrides for the TCA are processed after the global categories are registered (in ExtensionManagementUtility::buildBaseTcaFromSingleFiles()), most of the content types are just left out when the CategoryRegistry calls ExtensionManagementUtility::addToAllTCAtypes().


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #65922: Move unused tt_content TCA fields and the arrangement to css_styled_content or compatibility6ClosedPatrick Broens2015-03-23

Actions
Has duplicate TYPO3 Core - Bug #68650: Categories tab not showing on content elements starting with TYPO3 7.2Closed2015-07-30

Actions
Actions

Also available in: Atom PDF