Bug #68791

t3d export with FAL images not possible

Added by d.ros no-lastname-given over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Category:
Import/Export (T3D)
Target version:
-
Start date:
2015-08-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
nightmare
Is Regression:
No
Sprint Focus:

Description

  1. Summary

I export a single page with several content elements. No Problem.
As soon as a FAL image is within any element the export has not the file included and the import breaks with an error message.

TBH: This must be changed.

  1. error message
    Fatal error: Uncaught exception 'TYPO3\CMS\Core\Resource\Exception\FileDoesNotExistException' with message 'No file found for given UID.' 
    in /var/www/web1/html/subdomains/foo4/TYPO3.CMS/typo3/sysext/core/Classes/Resource/ResourceFactory.php:347 
    Stack trace: #0 /var/www/web1/html/subdomains/foo4/TYPO3.CMS/typo3/sysext/core/Classes/Resource/FileReference.php(91): TYPO3\CMS\Core\Resource\ResourceFactory->getFileObject('3190') 
    #1 /var/www/web1/html/subdomains/foo4/TYPO3.CMS/typo3/sysext/core/Classes/Utility/GeneralUtility.php(4436): TYPO3\CMS\Core\Resource\FileReference->__construct(Array) 
    #2 /var/www/web1/html/subdomains/foo4/TYPO3.CMS/typo3/sysext/core/Classes/Utility/GeneralUtility.php(4415): TYPO3\CMS\Core\Utility\GeneralUtility::instantiateClass('TYPO3\\CMS\\Core\\...', Array) 
    #3 /var/www/web1/html/subdomains/foo4/TYPO3.CMS/typo3/sysext/core/Classes/Resource/ResourceFactory.php(586): TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('TYPO3\\CMS\\Core\\...', Array) #4 /var/www/web1/html/subdomains/foo4/TYPO3.CMS/t in /var/www/web1/html/subdomains/foo4/TYPO3.CMS/typo3/sysext/core/Classes/Resource/ResourceFactory.php on line 347
    
  1. Additional note
    Originally I blamed flux for that.
    https://github.com/FluidTYPO3/fluidcontent/issues/259

Files

test-patch-68791.t3d (239 KB) test-patch-68791.t3d Bernhard Kraft, 2016-01-15 14:59
test-patch-68791-ext.t3d (239 KB) test-patch-68791-ext.t3d Bernhard Kraft, 2016-01-15 14:59
#1

Updated by Frans Saris over 6 years ago

  • Status changed from New to Needs Feedback

TBH: your are invited to improve current behaviour ;)

Did you select sys_file and sys_file_reference to be included in your export? Do you see the files in the preview below the export settings?

Gr. Frans

#2

Updated by d.ros no-lastname-given over 6 years ago

I included every table.

BTW: Got some voices on slack that FAL export just does not work.

#3

Updated by Alexander Opitz about 6 years ago

Hi d.ros,

does this issue still exists in latest (6.2.15) version? Maybe, did you test this issue already with one of the TYPO3 7.x versions?

#4

Updated by Markus Klein almost 6 years ago

  • Status changed from Needs Feedback to New

I can confirm the issue also for CMS 7, but it is really hard to tell if the mistake is a wrong selection of tables to include, or if it's really an import issue.
Nevertheless, an exception must not hit the user.

#5

Updated by Anja Leichsenring almost 6 years ago

  • Sprint Focus set to On Location Sprint
#6

Updated by Bernhard Kraft almost 6 years ago

Are your files located in a sys_file_storage which is not the default "/fileadmin" ? If this is the case: Does the directory of the sys_file_storage already exist on the target? Because a target directory for sys_file_storage will not get created automatically.

#7

Updated by Bernhard Kraft almost 6 years ago

  • Status changed from New to In Progress
  • Assignee set to Bernhard Kraft
  • % Done changed from 0 to 30
#8

Updated by d.ros no-lastname-given almost 6 years ago

Hello Bernhard,

thanks for your effort. IIRC it was located in a subdirectory of "~/fileadmin" . IMHO target directory should get created though.

Cheers

#9

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45940

#10

Updated by Bernhard Kraft almost 6 years ago

The attached T3D files can get used for testing this issue. Without the patch applied there will be no error message prior to import. After import there will be an error message in the "Messages" tab. The file "Lagerfeuer.jpg" will not get imported and is missing then.

In the "media" field (Tab "Resources") of the newly imported page "Media page" there will only be one image which resides in the default storage. The other image will be missing.

The second T3D "test-patch-68791-ext.t3d" will show an additional error message about the non-installed extension "taskcenter". Of course only if it really is not installed.

#11

Updated by Bernhard Kraft almost 6 years ago

The error message will get shown until there is a directory "fileadmin/sub" which is the target for the newly imported sys_file_storage.

#12

Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45940

#13

Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45940

#14

Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45940

#15

Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45940

#16

Updated by Gerrit Code Review almost 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45940

#17

Updated by Gerrit Code Review almost 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45940

#18

Updated by Bernhard Kraft almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 30 to 100
#19

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/45975

#20

Updated by Bernhard Kraft almost 6 years ago

  • Status changed from Under Review to Resolved
#21

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/46116

#22

Updated by Markus Klein almost 6 years ago

  • Status changed from Under Review to Resolved
#23

Updated by Mathias Schreiber over 5 years ago

  • Sprint Focus deleted (On Location Sprint)
#24

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF