Project

General

Profile

Actions

Bug #70158

closed

Moving a page in the page tree with click&hold on the page icon isn't possible anymore

Added by Tobias Wollender over 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2015-09-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
Soft-Merge Sprint

Description

I'm currently trying out latest 7 master (shortly before 7.5) and have a problem with moving pages in the page tree. In 6.2 LTS I can move a page by click&hold on the icon or the title of a page. In latest master this is only possible when click&hold on the title. The icon doesn't have this possibility anymore.

Is this intended? Will lead to many users thinking their TYPO3 is broken :)


Files

Schermata 2016-06-05 alle 16.41.43.png (39.6 KB) Schermata 2016-06-05 alle 16.41.43.png Riccardo De Contardi, 2016-06-05 16:48

Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Task #69754: Replace IconUtility::getSpriteIconForRecord with IconFactory->getIconForRecordClosedStephan GroƟberndt2015-09-13

Actions
Related to TYPO3 Core - Bug #76225: Drag'n'drop pages within pagetree not possible if clicked on page iconClosed2016-05-18

Actions
Related to TYPO3 Core - Feature #82426: Replace ExtJS page tree with SVG oneClosedTymoteusz Motylewski2017-09-09

Actions
Actions #1

Updated by Daniel Goerz over 8 years ago

  • Priority changed from Should have to Must have
  • Target version changed from 7.5 to 7 LTS
  • Is Regression changed from No to Yes

Introduced with #69754

Actions #2

Updated by Daniel Goerz over 8 years ago

  • Status changed from New to Accepted
Actions #3

Updated by Riccardo De Contardi over 8 years ago

  • Category set to Pagetree

Still present on 7.6-dev (latest master)

Actions #4

Updated by Riccardo De Contardi about 8 years ago

  • Target version changed from 7 LTS to Candidate for patchlevel
Actions #5

Updated by Jo Hasenau almost 8 years ago

  • Status changed from Accepted to Needs Feedback
  • Priority changed from Must have to Could have

We discussed that at the sprint in Karlsruhe and the point is, that there is a new tool tip on the icon now, which can be activated using a tablet as well.
My guess is, that this disables any dragging options, since it will be triggered by similar events.

So the question is, if we really need to reactivate the old behaviour or if it would be anough to drag things around by clicking on the text instead of the icon.

Actions #6

Updated by Riccardo De Contardi over 7 years ago

The current situation is shown on the attached screenshot Schermata 2016-06-05 alle 16.41.43.png

It would be nice to enable the drag and drop also for the "non draggable area" (except the icon for the reasons mentioned on the previous comments)

Actions #7

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New
Actions #8

Updated by Riccardo De Contardi over 6 years ago

  • Related to Feature #82426: Replace ExtJS page tree with SVG one added
Actions #9

Updated by Riccardo De Contardi about 6 years ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for patchlevel)

We are very sorry to close this one, but with the new pagetree developed for version 9 this issue will no more be present; our efforts will now concentrate on finalizing the new component.

If you think that this is the wrong decision, please reopen it or open a new issue with a reference to this one.

Actions

Also available in: Atom PDF