Bug #71570

CE "Special Menus" > pages hidden in menu are always excluded

Added by Riccardo De Contardi over 3 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Category:
Fluid Styled Content
Start date:
2015-11-14
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I noticed that when I use the Fluid Styled content "Special Menus" (for example "menu of selected pages"), the pages that are marked as "hide in menu" are excluded from the menu.

In the old CSC Menu built with HMENU this behavior could be reverted with includeNotInMenu = 1

please bring back this functionality because it was very useful (esp. on the sitemap)

I add a relation to #71311 because I think it is related (or even the same)


Related issues

Related to TYPO3 Core - Bug #71311: CE Special/Menu IncludeNotInMenu Closed 2015-11-04
Related to TYPO3 Core - Bug #71731: No section index menu when page is hidden in menus Closed 2015-11-20
Duplicated by TYPO3 Core - Feature #75874: Include pages for CE Menu/Sitemap they are marked as "not in Menu" Closed 2016-04-22

Associated revisions

Revision 80fec593 (diff)
Added by Benjamin Kott over 2 years ago

[!!!][FEATURE] Streamline Fluid Styled Content and CSS Styled Content

CSS Styled Content has been a long time the preferred way of rendering
content in the frontend. Fluid Styled Content was introduced as
successor of CSC, but the feature set diverged from the beginning. The
lack of flexibility and incomplete feature set in comparision to CSC
made it hard to migrate existing instances.

Since TYPO3 CMS 7.6 Fluid-Templates are the defined standard and
official recommendation for content rendering. The feature set of FSC is
now matching CSC. Both content renderings are now streamlined to be
fully compatible with each other. For the period of CMS 8 LTS CSC will
share the same capabilities to make an transition as easy as possible.
CSC is now deprecated and goes into maintenance mode and will be removed
with CMS 9.

For compatibility, CSC is now supporting Textmedia that was before
exclusive to FSC. But also FSC has learned some tricks from CSC. Fluid
Styled Content has now support for all content elements prior existing
only in CSC, this includes "Text", "Text and Images" and "Images". Also
for example "Frames", "Space before" and "Space after" are now again
featured across both content rendering methods.

Releases: master
Resolves: #79622
Resolves: #72422
Resolves: #75466
Resolves: #71570
Resolves: #71484
Change-Id: I7d2a9072baad508b6b87470b847444b91e7323fb
Reviewed-on: https://review.typo3.org/51065
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Daniel Goerz over 3 years ago

  • Assignee deleted (Benni Mack)
  • Target version changed from 7 LTS to Candidate for patchlevel

#2 Updated by Daniel Goerz over 3 years ago

From #71731 (closed as duplicate) posted by Robert Heinig:

To solve this problem the view helper "ce:menu.list" within the partial
EXT:fluid_styled_content/Resources/Private/Partials/Menu/Type-3.html
could be called with attribute includeNotInMenu="1".

#3 Updated by Richard Haeser over 3 years ago

  • Assignee set to Richard Haeser

#4 Updated by Johannes C. Laxander about 3 years ago

The same problem also relates CE Menu/Sitemap, type "Menu of subpages...", partial "Menu/Type-1.html":
To set the parameter "includeNotInMenu" in the fluid template is not a practical way, because you must create additional Templates when you will both menu/sitemaps with or without pages hidden in menu.

A better solution I think, is set "includeNotInMenu" in the properties of the content element.

#5 Updated by Bjoern Jacob over 2 years ago

A fast workaround is to make us of the tt_content.layout field.

Create a new layout item

TCEFORM {
    tt_content {
        layout {
            altLabels {
                4 = Menu - include not in menu
            }

            types {
                menu {
                    addItems.4 = menu-includeNotInMenu
                }
            }
        }
}

Improve partial

Copy your partial (for example Type-3.html and adapt code:

<html xmlns:f="http://typo3.org/ns/TYPO3/CMS/Fluid/ViewHelpers" xmlns:ce="http://typo3.org/ns/TYPO3/CMS/FluidStyledContent/ViewHelpers" data-namespace-typo3-fluid="true">

<f:section name="menuElement">
    <f:if condition="{pages}">
        <ul class="ce-menu ce-menu-3">
            <f:for each="{pages}" as="page">
                <ce:menu.section pageUid="{page.uid}" as="contentElements" type="header">
                    <f:if condition="{contentElements}">
                        <f:for each="{contentElements}" as="contentElement">
                            <li>
                                <f:link.page pageUid="{page.uid}" section="c{contentElement.uid}">
                                    {contentElement.header}
                                </f:link.page>
                            </li>
                        </f:for>
                    </f:if>
                </ce:menu.section>
            </f:for>
        </ul>
    </f:if>
</f:section>

<f:if condition="{data.layout} == 4">
    <f:then>
        <ce:menu.list pageUids="{pageUids}" as="pages" includeNotInMenu="1">
            <f:render section="menuElement" arguments="{pages: pages}"/>
        </ce:menu.list>
    </f:then>
    <f:else>
        <ce:menu.list pageUids="{pageUids}" as="pages">
            <f:render section="menuElement" arguments="{pages: pages}"/>
        </ce:menu.list>
    </f:else>
</f:if>

</html>

Works for me for now but having a backend representation is nicer.

#6 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 66 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#7 Updated by Gerrit Code Review over 2 years ago

Patch set 67 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#8 Updated by Gerrit Code Review over 2 years ago

Patch set 68 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#9 Updated by Gerrit Code Review over 2 years ago

Patch set 69 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#10 Updated by Gerrit Code Review over 2 years ago

Patch set 70 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#11 Updated by Gerrit Code Review over 2 years ago

Patch set 71 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#12 Updated by Gerrit Code Review over 2 years ago

Patch set 72 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#13 Updated by Gerrit Code Review over 2 years ago

Patch set 73 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#14 Updated by Gerrit Code Review over 2 years ago

Patch set 74 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#15 Updated by Gerrit Code Review over 2 years ago

Patch set 75 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#16 Updated by Gerrit Code Review over 2 years ago

Patch set 76 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#17 Updated by Gerrit Code Review over 2 years ago

Patch set 77 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#18 Updated by Gerrit Code Review over 2 years ago

Patch set 78 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#19 Updated by Gerrit Code Review over 2 years ago

Patch set 79 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#20 Updated by Gerrit Code Review over 2 years ago

Patch set 80 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#21 Updated by Gerrit Code Review over 2 years ago

Patch set 81 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#22 Updated by Gerrit Code Review over 2 years ago

Patch set 82 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#23 Updated by Gerrit Code Review over 2 years ago

Patch set 85 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#24 Updated by Gerrit Code Review over 2 years ago

Patch set 86 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/51065

#25 Updated by Anonymous over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#26 Updated by Benni Mack 9 months ago

  • Status changed from Resolved to Closed

#27 Updated by filigivuji filigivuji about 1 month ago

How exactly did the mentioned changeset solve this issue?

I found out how to include pages hidden in menu e.g. in the "Menu Pages" content element in TYPO3 9.5 (see MenuPages.typoscript for reference):

tt_content.menu_pages.dataProcessing.10.includeNotInMenu = 1

However I don't see how you could set this specifically per content element instance.

Also I'm not sure if the current default of includeNotInMenu makes sense for menu_pages (which is supposed to be a menu of user-selected pages), since one might argue that if users select pages in the content element they want them to be shown regardless of whether the pages are being set to be hidden in menus.

Also available in: Atom PDF