Bug #71619

Story #69617: FormEngine bugs

FAL relation with min=1, max=1 not deletable

Added by Christian Weiske almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-11-17
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I've got a fluid content element with a FAL relation field that has a minimum setting of 1, as well as maximum of 1.

When creating the element, there are the default "Create new relation" and "Select & upload files" buttons. They disappear after I selected an image and save.

However, I cannot remove the image and replace it with another one. Clicking the "delete" of the image does not make it go away, only renders the images.


Related issues

Related to TYPO3 Core - Bug #66832: Fileupload in a record fails with TCA for "exactly one file" (minitems/maxitems=1) Closed 2015-05-07
Blocked by TYPO3 Core - Bug #71436: Inline in flex with multiple DS fails Closed 2015-11-09
Blocked by TYPO3 Core - Bug #71564: FAL file pick in flexform causes error 500 alert box Closed 2015-11-13

History

#1 Updated by Mathias Schreiber over 3 years ago

  • Parent task set to #69617

#2 Updated by Frank Naegler over 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Frank Naegler

#3 Updated by Frank Naegler over 3 years ago

  • Status changed from In Progress to Needs Feedback

I have tested several configurations, but I can't reproduce the bug.
Can you please provide an example configuration or extension to reproduce the problem?

#4 Updated by Christian Weiske over 3 years ago

The issue happens in TYPO3 7.6.0, 7.6.1 and 7.6.2.

It does not happen anymore in 7.6.3 or 7.6.4.

You can close this issue.

#5 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Frank Naegler)

Closed as resolved in 7.6.3+

Thank you for your time and feedback

#6 Updated by Christian Kuhn over 3 years ago

  • % Done changed from 0 to 100

Also available in: Atom PDF